Opened 3 years ago

Closed 3 years ago

#10851 closed enhancement (fixed)

libinput-1.11.0

Reported by: Bruce Dubbs Owned by: ken@…
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version,

Change History (6)

comment:1 by ken@…, 3 years ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:2 by ken@…, 3 years ago

Not convinced.

On a build from 20180531 on another machine, I used 1.10.7. From time to time (sometimes when machine seemed to be idle, other times when it was flat-out compiling) keyboard input would disappear (type a word or two, some letters eventually appears, but not all of them; tab to a different window and nothing happened although the mouse seemed to work) and at other times no visible result would suddenly turn into a *lot* of repeated characters - either spaces, or one letter.

Using 1.11.0 I've now seen similar issues on the current (2018-06-15) build.

Most of the time, both systems work ok.

I see intermittent similar reports for libinput over the years (some of them on Wayland), but no guidance of where the problem might lie. One (Wayland) report got a suggestion from PH to run /usr/libexec/libinput/libinput-debug-events to see if that reported missed events. But that needs to be left running and every keypress/release or mouse movement is reported in normal use - so it would have to be open, and visible, on the current desktop at the time the problem occurred.

The real trouble is that because it is mostly ok, it becomes very hard to determine if a particular release is ok, let alone to try bisecting.

comment:3 by Bruce Dubbs, 3 years ago

Try reverting and see if that fixes the issue.

in reply to:  3 comment:4 by ken@…, 3 years ago

Replying to bdubbs:

Try reverting and see if that fixes the issue.

I might do, but I need to look at versions I've used to see what might be good - and there is the problem of not knowing what provokes the problem.

comment:5 by ken@…, 3 years ago

Box got unusable for prolongued periods a few hours ago. Went back to evdev, similar - a couple of times, the keyboard decided to only give me shifted characters (!"£$% etc for digits) in X. Before that, tried a 4.17.0 kernel just in case. On one occasion I had to reboot, and on that occasion the first boot gave me 4 beeps and didn't move beyond the graphic card/EFI/BIOS announcement - i.e. no keyboard present, couldn't select BIOS etc. On rebooting again, ok until the next batch of problems (and some are in a tty).

So, I've concluded that these are all caused by a keyboard which is failing (currently typing on another machine connected to a different keyboard). Will pick this up when I have been able to measure it on the affected machine which has my current build.

comment:6 by ken@…, 3 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.