Opened 3 years ago

Closed 3 years ago

#10880 closed enhancement (fixed)

Recommend libssh2 for rustc, and therefore add it to the book

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Rustc seems to be a most capricious tool. Several times this year I have had installs which failed with

error: could not find native static library `ssh2`, perhaps an -L flag is missing?

That is in the libgit crate, just after the ssh2 crate.

On previous builds with this failure, I think that retries succeeded at the second or third attempt. Other fresh systems on the same machines, and later building of newer rustc versions or trying different options have generally succeeded, so I assumed this was something in the rust libs.

But on my latest new build I had at least 6 failed retries (sometimes throwing away what I had and repeating my script, other times manually retrying the (DESTDIR) install. Then I looked at Arch: they seem to have had libssh2 as a required dependency for some time.

After installing that, the next attempt to build rustc completed.

This reminds me of the mozilla build where on one occasion I had to add libnotify to get the install to complete, but on other occasions that had not been necessary. Perhaps it's Python which is actually the cause of this.

Change History (2)

comment:1 by ken@…, 3 years ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:2 by ken@…, 3 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.