Opened 3 years ago

Closed 3 years ago

#10966 closed enhancement (fixed)

subversion-1.10.2

Reported by: Douglas R. Reno Owned by: Bruce Dubbs
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point release

Change History (3)

comment:1 by thomas, 3 years ago

Owner: changed from blfs-book to thomas
Status: newassigned

https://svn.apache.org/repos/asf/subversion/trunk/CHANGES

Version 1.10.2 (20 Jul 2018, from /branches/1.10.x) http://svn.apache.org/repos/asf/subversion/tags/1.10.2

User-visible changes:

  • Client-side bugfixes:
    • Correctly claim to offer Gnome Keyring support with libsecret (r1831142)
    • Fix segfault using Gnome Keyring with libsecret (r1835782)
    • Fix JavaHL local refs capacity warning when unparsing externals (r1831143)
    • Since on Windows Subversion does not handle symlinks, never check for reparse points (r1835701)
    • Prune externals after 'update --set-depth=exclude' (r1835702)
    • Fix issue #4740, "conflict resolver searches too far back ..." (r1835703)
  • Server-side bugfixes:
    • Fix regression issue #4741: authz group refers to multiple groups (r1831220)

Developer-visible changes:

  • General:
    • Regression test and FSFS checksum test, part of issue #4722 (r1828043)
    • Explicit error on configure --without-lz4 or --without-utf8proc (r1831604)
    • configure.ac: Fix regression relating to path to 'rdoc' (r1833486)
    • Ensure consistent use of $PYTHON during build and test (r1833487)
    • Fix libsvn_auth_gnome_keyring.pc when built using libsecret (r1835781)
  • Bindings:
    • Fix regression in use of pre-generated Swig bindings in release builds (r1833488)

comment:2 by Bruce Dubbs, 3 years ago

Owner: changed from thomas to Bruce Dubbs
Status: assignednew

I'm going to take this since I just update it on my system.

comment:3 by Bruce Dubbs, 3 years ago

Resolution: fixed
Status: newclosed

Fixed at revision 20250.

Note: See TracTickets for help on using tickets.