Opened 3 years ago

Closed 3 years ago

#10979 closed enhancement (fixed)

xfwm4-4.12.5 (xfce)

Reported by: Bruce Dubbs Owned by: Tim Tassonis
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (2)

comment:1 by Tim Tassonis, 3 years ago

Owner: changed from blfs-book to Tim Tassonis
Status: newassigned

commit cfc967a10ad36a31b5776a2880c46c43ee03cc3c Author: Olivier Fourdan <fourdan@…> Date: Sun Jul 29 15:00:11 2018 +0200

Release 4.12.5!

Signed-off-by: Olivier Fourdan <fourdan@…>

commit d730ebb6244874805b3e37b6c0bb3b9328f2b23d Author: Olivier Fourdan <fourdan@…> Date: Sun Jul 22 10:58:42 2018 +0200

client: Check GTK_HIDE_TITLEBAR_WHEN_MAXIMIZED

Check that value for GTK_HIDE_TITLEBAR_WHEN_MAXIMIZED has actually changed before reconfiguring the window.

(cherry picked from commit 5f7a1f5f91fd0eec91a4a88c669847fd2567a270)

commit 18575f3a098c7bbb3a43838c7745e01efa260997 Author: Olivier Fourdan <fourdan@…> Date: Sun Jul 22 10:54:35 2018 +0200

client: Check when GTK_FRAME_EXTENTS has changed

Bug: 14511

GTK+ will update its GTK_FRAME_EXTENTS property continuously even when the value hasn't actually changed, which causes the maximized state to be cleared when transitioning to/from fullscreen to maximized.

Check that he extents have changed and reconfigure the client's window only when the value has changed.

(cherry picked from commit 0a5ba680f27a48242d52c590727deb837708da09)

commit 860b369474875442ff1e1b14589522a8db8e9804 Author: Olivier Fourdan <fourdan@…> Date: Wed Jul 18 15:28:23 2018 +0200

netwm: Fix adding maximized state

Bug 14514

xfwm4 would fail to add maximized states using extended window manager hints mechanisms.

(cherry picked from commit 5e1354886ae9b22c0fe86ba695ed7f0a63fed14e)

commit 020b0722b0d83e43ee295486ddffca504283f56a Author: Adam Purkrt <adam@…> Date: Sun Jan 21 17:51:37 2018 +0100

Typo in clientMoveTile

Bug: 14181

The comparison is corrected, closing a one pixel gap between TILE_LEFT and TILE_UP_LEFT and between TILE_RIGHT and TILE_UP_RIGHT.

(cherry picked from commit 4ec48e8d52ad5afefb20d00345967a1bcf27a34f)

commit 13b6fceb41e6275193939eb63431ef712d5a76ca Author: Olivier Fourdan <fourdan@…> Date: Thu Jan 18 21:18:04 2018 +0100

screen: Use computed screen size instead of xlib

When the xrandr layout is changed, we recompute the screen size on the actual monitors size and layout.

Use this computed value instead of the size reported by Xlib as it's not yet updated by the time we reconfigure our display. This is particularly bad when the compositor is enabled as the overlay window end up being of the wrong size.

(cherry picked from commit 480517d49d3e4cf48357fbe47d193f62542ab94b)

commit 11421dc28cf3a4ea6598eb32f48dc39da2c078db Author: Olivier Fourdan <fourdan@…> Date: Fri Dec 8 20:17:25 2017 +0100

client: Make sure to redraw when removing maximized

Bug: 13954

When a client issues a ConfigureRequest() on a toplevel window, that window may transition from maximized to un-maximized state.

Make sure we repaint and relocate the client window within the frame.

Signed-off-by: Olivier Fourdan <fourdan@…> (cherry picked from commit 87cbe0e3d01d467c14aa2bb4d3656bf6b39a4247)

commit 0f7f70f3b3ed0883bdca6989673dbd1cdffdd901 Author: Andrey Alekseenkov <zyx1984@…> Date: Tue Dec 5 10:55:30 2017 +0100

Fix logic error in bottom struts validation

Bug: 13964 (cherry picked from commit b6fa004ea1ad4d7db84730ae5f773cbc4b762eeb)

commit 0c00ec4c86003e053d2e68337929fad8d7bedff1 Author: P. Pronk <xfce@…> Date: Tue Jan 10 12:45:53 2017 +0100

client: Maximize on expected output

Bug: 13284

When dragging a window from a large monitor to the top of a smaller monitor to maximize the window, it is possible that the window gets maximised on a different monitor then the monitor your mouse is.

This happens because clientToggleMaximized uses the center point of the window to calculate on which monitor the window should be maximised.

To fix this behaviour this commits adds a clientToggleMaximizedAtPoint method so we can tell on which monitor the window should be maximised.

(cherry picked from commit 9c888ac750265b88a865cdbd01edf50395c82c54)

commit 2bd611c255570c04b2c092fee35caa6f4d43c663 Author: Olivier Fourdan <fourdan@…> Date: Thu Jun 1 09:30:40 2017 +0200

screen: Fix broken monitor index

Bug: 13608

Commit 5895577 (Use ximerama indices for _NET_WM_FULLSCREEN_MONITORS) introduced a regression because the monitor index was wrongly compared against the total number of monitors, which would falsely assume that the Xrandr query failed whereas it actually worked.

Fix the false comparison and also use the screen size as fallback values in case the Xrandr really failed so that we don't end up using random uninitialized values.

(cherry picked from commit 2aaf9e3328084cc268ffe290f7dd14d7327e1e50)

commit c3673a138bf8c3512a1d7382e7883a9f33af77ad Author: Olivier Fourdan <fourdan@…> Date: Mon May 1 22:15:49 2017 +0200

Use ximerama indices for _NET_WM_FULLSCREEN_MONITORS

Bug: 9351

_NET_WM_FULLSCREEN_MONITORS uses Xinerama indices for multi-monitor fullscreen, but xfwm4 uses gdk indices which may differ.

As a result, depending on the actual layout and which monitor is marked as primary, a fullscreen window could be placed on the wrong outputs.

Fetch the Xinerama list and use the monitor size from there instead of relying on gdk monitor indices for _NET_WM_FULLSCREEN_MONITORS

(cherry picked from commit 29e813a4fe7ad1dbe77a96dd841627fc567a6bd6)

commit e9d1de4c9bf4512760a512ecab7411ac08165f2a Author: Olivier Fourdan <fourdan@…> Date: Thu Mar 23 11:39:04 2017 +0100

placement: Use primary monitor as default

Bug: 13454

We would use the first monitor by default, but we'd rather use the primary monitor.

Signed-off-by: Olivier Fourdan <fourdan@…> (cherry picked from commit dee7e7e5019b14f0f76eb8be962ffa9502e346e4)

commit 37b4d438201d08ebe995a0910ce37575c158f54b Author: Olivier Fourdan <fourdan@…> Date: Tue Mar 21 09:56:41 2017 +0100

netwm: avoid spurious warning on restart

NET_WM_STATE_FOCUS is set by the WM itself, it's not an unknown property.

(cherry picked from commit 84ef731d4ccf167886d4d2ed0557ebf8882105d7)

commit a598b94c67e20b1dae2ead80d6fdcd823e3fe710 Author: Unit 193 <unit193@…> Date: Fri Mar 17 17:57:18 2017 -0400

Fix a spelling mistake.

(cherry picked from commit 087decc60f7c8c94e0f9734bdb66d910b8aea59a)

comment:2 by Tim Tassonis, 3 years ago

Resolution: fixed
Status: assignedclosed

Fixed in revision 20256.

Note: See TracTickets for help on using tickets.