Opened 20 years ago

Closed 18 years ago

Last modified 13 years ago

#11 closed defect (fixed)

alsa 0.9.6

Reported by: markh@… Owned by: iwanek@…
Priority: normal Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc: TOttmar@…

Description

These might need extra entities creating in index.xml for versions etc

ALSA driver 0.5.11

ALSA library 0.5.10b

ALSA utils 0.5.10

URL is somewhere around www.alsa-project.org/

Change History (42)

comment:1 by markh@…, 20 years ago

Owner: changed from blfs-book@… to markh@…
Status: newassigned

comment:2 by markh@…, 20 years ago

alsa-driver 0.5.12 is now out.

suggest we remain with the 0.5.x series for now. The 0.9beta series cause too many compile problems ATM.

comment:3 by markh@…, 20 years ago

Resolution: fixed
Status: assignedclosed

written by Alex Kloss and put into cvs by markh

comment:4 by markh@…, 20 years ago

Milestone: 1.0

comment:5 by bdubbs@…, 19 years ago

Resolution: fixed
Status: closedreopened

The ALSA instructions need to be updated. First, there needs to be a note that says you need to disable OSS in the kernel -- it took me hours to figure this out.

There also needs to be a discussion of ISA sound cards. ISA cards need the configure switch --with-isapnp=yes. Also, the --with-moddir does not need to be set if the kernel source is in /usr/src/linux as it normally is.

The modules.conf needs the statement:

alias char-major-14 soundcore

when isa cards are used.

I also had a problem with compiling the drivers for an AWE64 card. There was a bug in one of the alsa-driver-0.9.0rc1 Makefiles that resulted in modprobe giving an undefined external. In alsa-kernel/core/Makefile, the line: obj-$(CONFIG_SND_SBAWE) += snd-pcm.o snd-timer.o snd.o snd-rawmidi.o

needs to have snd-hwdep.o appended at the end.

Last, the instructions need a section on how to verify that ALSA is working. You have to set the mixer volume (in my case to 100%) to hear the sounds. A brief instruction on how to use alsamixer and aplay should be added.

comment:6 by iwanek@…, 19 years ago

taken from www.alsa-project.org:

* N.B. The 0.5.x series is considered deprecated and is no longer supported by ALSA developers *

the current version is 0.9.0rc1 - we really should drop 0.5.* now

comment:7 by iwanek@…, 19 years ago

Summary: alsa-sound 0.5.xalsa-sound 0.9.0rc1

comment:8 by markh@…, 19 years ago

In response to the above comment, I'll drop 0.5.x support when the alsa team officially release the final 0.9.0 version. At this point, I'll hopefully also rewrite certain parts of the page which need reworking. At that point I'll also as Alex if he has any changes / additions to make to the page.

comment:9 by markh@…, 19 years ago

Dieter Scholz reported this on blfs-dev:


Hi,

the default config file for Alsa is /etc/asound.state not /etc/asound.conf as stated in the BLFS book (see top of alsactl.c file in the utils archive).

Perhaps you should change this.


When the alsa update is done, check this out.

comment:10 by iwanek@…, 19 years ago

Summary: alsa-sound 0.9.0rc1alsa-sound 0.9.0rc2

new version - 0.9.0RC2

comment:11 by markh@…, 19 years ago

From my mail to blfs-book:

On Sat, 08, Jun, 2002 at 12:26:37AM +0100, James Iwanek spoke thus..

mark - what are we going to do with this one?

OK, now I've had a chance to try the alsa-0.9.x series I agree that it's time to dump the 0.5.x support; although it's still in -rc stage it seems OK to me.

I've altered Bugzilla to note this fact.

Mark

comment:12 by highos@…, 19 years ago

Summary: alsa-sound 0.9.0rc2alsa-sound 0.9.0rc3

Version increment.

comment:13 by markh@…, 19 years ago

Status: reopenedassigned

Beginning complete overhaul and rewrite of alsa section.

comment:14 by markh@…, 19 years ago

Cc: TOttmar@… added

comment:15 by markh@…, 19 years ago

* Bug 104 has been marked as a duplicate of this bug. *

comment:16 by markh@…, 19 years ago

Resolution: fixed
Status: assignedclosed

Rewrite committed to book. Should fix all issues mentioned in bugzilla (this bug and bug 104)

comment:17 by highos@…, 19 years ago

Resolution: fixed
Status: closedreopened
Summary: alsa-sound 0.9.0rc3alsa 0.9.0rc5

Version increment (0.9.0rc5)

comment:18 by highos@…, 19 years ago

Summary: alsa 0.9.0rc5alsa 0.9.0rc6

Version increment (0.9.0rc6)

comment:19 by highos@…, 19 years ago

Summary: alsa 0.9.0rc6alsa 0.9.0rc7

Vesion increment (0.9.0rc7)

comment:20 by markh@…, 19 years ago

Status: reopenedassigned

comment:21 by highos@…, 19 years ago

Summary: alsa 0.9.0rc7alsa 0.9.0rc8

Version increment (0.9.0rc8)

comment:22 by highos@…, 19 years ago

Summary: alsa 0.9.0rc8alsa 0.9.0rc8a

Version increment (0.9.0rc8a);

0.9.0rc8a released (fixed compilation problem for older kernels)
(fixed

compilation problem)

comment:23 by highos@…, 19 years ago

Summary: alsa 0.9.0rc8aalsa 0.9.0rc8b

Version increment (0.9.0rc8b)

comment:24 by iwanek@…, 19 years ago

all bugs except for the one bruce mentions about the miscompiling AWE64 module should now be fixed.

comment:25 by iwanek@…, 19 years ago

alsa-lib 0.9.0rc8c and alsa-utils 0.9.0rc8a released

comment:26 by iwanek@…, 19 years ago

alsa-lib 0.9.0rc8c and alsa-utils 0.9.0rc8a released

comment:27 by iwanek@…, 19 years ago

Summary: alsa 0.9.0rc8balsa 0.9.0rc8c

comment:28 by highos@…, 19 years ago

Version increment (0.9.0rc8d)

comment:29 by highos@…, 19 years ago

Summary: alsa 0.9.0rc8calsa 0.9.0rc8d

comment:30 by iwanek@…, 19 years ago

Owner: changed from markh@… to chthon@…
Status: assignednew
Summary: alsa 0.9.0rc8dalsa 0.9.1

0.9.1 stable released - patch will be forthcoming once ive installed my new kernel ;-)

comment:31 by iwanek@…, 19 years ago

Status: newassigned

comment:32 by iwanek@…, 19 years ago

the bug relating to AWE64 and snd-hwdep.o has been fixed in 0.9.x late rc's all we need now is a bit of text on using alsamixer

comment:33 by highos@…, 19 years ago

Summary: alsa 0.9.1alsa 0.9.2

Version increment (0.9.2)

comment:34 by tushar@…, 19 years ago

Resolution: fixed
Status: assignedclosed

comment:35 by highos@…, 18 years ago

Resolution: fixed
Status: closedreopened
Summary: alsa 0.9.2alsa 0.9.3

Version increment (0.9.3)

comment:36 by highos@…, 18 years ago

Summary: alsa 0.9.3alsa 0.9.3a

Version increment (0.9.3a)

comment:37 by highos@…, 18 years ago

Summary: alsa 0.9.3aalsa 0.9.4

Version increment (0.9.4)

comment:38 by tushar@…, 18 years ago

Resolution: fixed
Status: reopenedclosed

comment:39 by highos@…, 18 years ago

Resolution: fixed
Status: closedreopened
Summary: alsa 0.9.4alsa 0.9.5

Version increment (0.9.5)

comment:40 by igor@…, 18 years ago

Summary: alsa 0.9.5alsa 0.9.6

Version increment (0.9.6)

comment:41 by larry@…, 18 years ago

Resolution: fixed
Status: reopenedclosed

comment:42 by (none), 13 years ago

Milestone: 1.0

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.