Opened 3 years ago

Closed 3 years ago

#11000 closed enhancement (fixed)

boost-1_68_0

Reported by: Bruce Dubbs Owned by: ken@…
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version.

Change History (7)

comment:1 by ken@…, 3 years ago

At least one change which breaks things. The file /usr/include/boost/uuid/sha1.hpp was a normal header in 1_64_0, but by 1_66_0 it was marked as deprecated and included /usr/include/boost/uuid/sha1.hpp. In 1_68_0 it has gone, I found https://github.com/boostorg/uuid/issues/70 which for this says

*Breaking change:] sha1 detail namespace header redirection for backwards compatibility was removed ([github_pr uuid 69]).

Unfortunately, that is used by libcmis which is one of the tarballs downloaded by libreoffice. Because the downloads happen during the build, it is inconvenient to let it break, stop, fix the accected file(s), resume.

A workaround (still building LO, but I've got a lot further) will be to symlink that file immediately after installing boost:

ln -svf detail/sha1.hpp /usr/include/boost/uuid/sha1.hpp

comment:2 by ken@…, 3 years ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:3 by ken@…, 3 years ago

The keyboard on that machine became intermittent a few hours ago, but for a while it recovered and dmesg showed it disappearing and then reappearing. But then it disappeared completely and rebooting errored with no keyboard present.

If I can get a new keyboard I might be able to pick this up again. If not, my current notes are (for -j4)

size: 88MB md5sum: 7fbd1890f571051f2a209681d57d486a

instructions:

  1. for tests, Python-2.7.15 is in parentheses
  2. for testing, the comment about a file needing to be renamed should go. That was for an earlier version where zlib.py needed to be renamed - that instruction went, the lead-in comment did not.
  3. add something like

ln -svf detail/sha1.hpp /usr/include/boost/uuid/sha1.hpp

The <filename>uuid/sha1.hpp</filename> used to be a regular header, but by boost_1_66_0 it had been changed to load the similar <filename>detail/sha1.hpp</filename> header, with a message that it had been deprecated. It has now been removed, but not every package which uses it has been changed and in particular one of the libraries downloaded as a git version by libreoffice.

  1. for basic build, now 2.6 SBU and 1.3GB total (1.1GB build, 204MB installed).
  1. basic tests take 1.2 SBU and use an extra 1MB.
  1. for regression tests with -j4 now 119 SBU but space unkknown (the directory should still be there, but I can't boot).

At the start of the output from the regression tests there were messages about something unescaped and something non-free, but since I can't boot, I can't read the log I saved.

comment:4 by ken@…, 3 years ago

New keyboard. The test warnings can be happily ignored. Build now 47GB.

Old figures for regression tests were over 120 SBU at -j1, 50 SBU at -j4, now 119 SBU at -j4 on a haswll i7 : I don't think anybody will want to run them at -j1.

comment:5 by Bruce Dubbs, 3 years ago

Really 47 GB??? The tests seem grossly unreasonable.

I have built boost_1_68_0 but I didn't run the tests.

in reply to:  3 comment:6 by ken@…, 3 years ago

Replying to ken@…:

  1. for basic build, now 2.6 SBU and 1.3GB total (1.1GB build, 204MB installed).

Correction: I had accidentally omitted the link=shared after I got fed up waiting for the DESTDIR-style install to finish (see the wiki) and restarted using -j4. Noticed when I came to check the libs against the book.

With that corrected, build is same size but a little slower, install is also similar size (according to df -h) but slightly slower, total now 2.7 SBU.

comment:7 by ken@…, 3 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.