Opened 3 years ago

Closed 3 years ago

#11007 closed defect (fixed)

gimp: consider not building help.

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

I have become aware that whilst the text in git pulls for gimp help renders correctly, and the pngs for navigation and for the splash logo (the mushrooms) in the index are fine, no other pngs are linked in the html from my process, although they are present in the online help.

Looking at just the 'en' help, the image of Wilber in gimp-first-steps.html does not appear, only the caption.

<div class="mediaobject"><img src="" alt="Wilber, the GIMP mascot" /><div class="caption">

Note the empty src= string.

I asked on gimp-dev a week ago (not sure if that is the right list, there is only one dev and he might be on vacation or busy with other things) https://mail.gnome.org/archives/gimp-developer-list/2018-August/msg00008.html and have so far had no response.

The online help requires gvfs, which I have not normally built, but once it is set up the help will always be the latest version. Therefore, if not building the help recommend gvfs.

Adding the optional png progs (one needed a sed to build), or the switches --enable-network, --enable-maintainer-mode made no difference.

Change History (12)

comment:1 by Bruce Dubbs, 3 years ago

We may want to use https://download.gimp.org/pub/gimp/help/gimp-help-nightly.tar.bz2 and not include an md5sum. For other stats just add (as of <date>).

comment:2 by ken@…, 3 years ago

No responses to my query about building this. Looking at fedora, they are still using the 2.8.2 help (and patching it to specify python2 because their python is actually python3).

For my own builds, I've changed to the online help because it is more up to date, but I suppose we could revert the help to 2.8, with a recommendation for the online help because it is up to date, but showing how to build the 2.8 help.:w

comment:3 by ken@…, 3 years ago

The pre-formatted online help is also available at https://docs.gimp.org/2.10/en/index.html Change the 'en' to another language if preferred, but not all are fully translated.

Comparing 2.10 to 2.8, it looks as if a lot of hte text has not yet been updated, so perhaps 2.8 will be adequate for most people.

comment:4 by ken@…, 3 years ago

Owner: changed from blfs-book to ken@…
Status: newassigned

LOL, I get the same problem with 2.8.2. Following the instructions in 8.2, build it for just 'en'. Then open html/en/gimp-first-steps.html in e.g. firefox.

Scroll down to

  1. Basic Concepts

There is ONLY text in a box:

Figure 3.1. Wilber, the GIMP mascot

Wilber, the GIMP mascot

The Wilber_Construction_Kit (in src/images/) allows you to give the mascot a different appearance. It is the work of Tuomas Kuosmanen (tigertATgimp.org).

The line after the figure is the caption, but the image is not present. I'll have to dig out an 8.2 system to see if htat was similar.

comment:5 by ken@…, 3 years ago

Found an 8.2 system where I had not updated gimp (still 2.8 with 2.8.2 help). The problem is present there too, so nothing new! And nobody has remarked on it until I noticed it.

I'll prepare a fresh tarball from git, then (for 8.3) it can be uploaded to anduin.

I'll also add a note that some pngs are missing for unknown reasons, and that using the online help is therefore preferred.

Apparently, if dblatex (and xetex) are installed, PDFs can be created - bet they will have the same problem.

in reply to:  5 comment:6 by Bruce Dubbs, 3 years ago

Replying to ken@…:

I'll prepare a fresh tarball from git, then (for 8.3) it can be uploaded to anduin.

I was just going to suggest that. Have you looked at what other distros do?

comment:7 by ken@…, 3 years ago

Looked at fedora - they require dblatex and the two png progs, but the first is for PDFs and the progs are to reduce space in a distro.

It worked in BLFS-8.1! The likely culprits are libxml2 (2.9.4 worked, 2.9.7 didn't) and libxslt (1.1.29 worked, 1.1.32 didn't). I'll try putting old versions of both (xslt tends to need a matching xml2) in /opt to see if it fixes it.

If it does, I'll provide a <note> for them. This also affects the python2 part of python-modules.html#libxml2py2 : IFF I can get it to work, I suppose the details re /opt (PATH, PKG_CONFIG_PATH belong there : and ONLY used for this. But maybe they won't play nice.

comment:8 by Bruce Dubbs, 3 years ago

I do not think it is "cheating" if we just supply the docs in formatted form. Please do not spend a lot of time trying to explain how the docs are generated.

I note that most packages provide formatted man pages and we really don't worry much about how they are generated.

comment:9 by ken@…, 3 years ago

I put libxml2-2.9.4 and libxslt-1.1.29 into /opt/oldxml2 but no better. For the record, libxml2 configured with

./configure --prefix=/opt/oldxml2 --disable-static

and libxslt needed

PATH=/opt/oldxml2/bin:$PATH \
 ./configure --prefix=/opt/oldxml2 \
 --with-python=/usr/bin/python2.7 \
 --disable-static

(The --with-python was to stop it putting the libxslt module in /opt/oldxml2/lib/python2.7/site-packages)

Summary:

gvfs should be recommended

note that the formatted help is also available online, with link

build latest help but note that for unknown reasons some of the png images do not get linked from the html so that only their captions are visible.

comment:10 by ken@…, 3 years ago

Size of the snapshot is 172 MB.

comment:11 by ken@…, 3 years ago

gimp-help-2018-08-21.tar.xz uploaded to my public_html/ at anduin

comment:12 by ken@…, 3 years ago

Resolution: fixed
Status: assignedclosed

Addressed at r20372 (not 'fixed', I have no idea what broke the local builds)

Note: See TracTickets for help on using tickets.