Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11139 closed enhancement (fixed)

openjdk-11.0.2+7

Reported by: Bruce Dubbs Owned by: Pierre Labastie
Priority: normal Milestone: 8.4
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New major version.

Change History (15)

comment:1 by Pierre Labastie, 4 years ago

Summary: jdk-11+28openjdk-11.0.1+13

Now 11.0.1+13.

comment:2 by Pierre Labastie, 4 years ago

Owner: changed from blfs-book to Pierre Labastie
Status: newassigned

comment:3 by Pierre Labastie, 4 years ago

Hmmm, jdk-11.0.2 is already available with a commercial licence from Oracle. I'd better wait...

comment:4 by Pierre Labastie, 4 years ago

Summary: openjdk-11.0.1+13openjdk-11.0.2+7

Now openjdk-11.0.2+7 is out...

comment:5 by Pierre Labastie, 4 years ago

The tests had ~40 failures for 64 bit and ~60 failures for 32 bit. Furthermore, there are no 32 bit binary jdk available (either free or commercial licence). I've uploaded a self made binary 32 bit JVM to anduin, but I am not sure it is safe to use it.

For the 64 bit binary, I've opted to use the one at https://download.java.net/java/GA/jdk11/7/GPL/openjdk-11.0.2_linux-x64_bin.tar.gz, which has a GPLv2 license (with classpath exception).

comment:6 by Pierre Labastie, 4 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r20988

comment:7 by Douglas R. Reno, 4 years ago

As a heads up, Oracle pulled the binary for x86_64. I just discovered this while trying to install Java to see if I can reproduce a bug in Libreoffice that's affecting my 32-bit machine. I can probably generate a binary myself, but I'm more concerned about trying to reproduce the build issue I'm having.

comment:8 by Pierre Labastie, 4 years ago

I've seen that the build number was bumped to 9, because they had forgotten to update a date. I haven't bothered to push that change to the book... But if you have tried +7, maybe it's now +9. Yes the url is now: https://download.java.net/java/GA/jdk11/9/GPL/openjdk-11.0.2_linux-x64_bin.tar.gz. (see the 9 instead of the 7?)

comment:9 by Douglas R. Reno, 4 years ago

That's not working now either. I get a 404, and if you go to download.java.net, it says that it's been discontinued and redirects to the Oracle Downloads page.

comment:10 by Pierre Labastie, 4 years ago

I just used that to download the new file. It's also the link on https://jdk.java.net/11/. There is nothing saying it is discontinued...

comment:11 by Pierre Labastie, 4 years ago

I'm updating the book. I think I won't regenerate the 32 bit binary...

comment:12 by Douglas R. Reno, 4 years ago

I can take care of the 32-bit binary, no problems there.

http://anduin.linuxfromscratch.org/~renodr/JavaNetDiscontinuation.png

I was able to get it again by retrying, so I won't worry about the 64-bit binary and I'll just use the provided one. However I am concerned about the random 404s when trying to download the binary. Originally though, I copied the URL out of Thunderbird, so I wonder if that had something to do with it.

Are there any special instructions for generating the 32-bit binary? The system that's having issues with Libreoffice is my 32-bit box, and it loses its lunch while trying to build the hqsql stuff that's using Java.

in reply to:  12 comment:13 by Pierre Labastie, 4 years ago

Replying to renodr:

I can take care of the 32-bit binary, no problems there.

thanks. I you build it, you can upload it, but I don't think it is necessary: this is just a change in the release date (which was still saying October 2018)

Are there any special instructions for generating the 32-bit binary? The system that's having issues with Libreoffice is my 32-bit box, and it loses its lunch while trying to build the hqsql stuff that's using Java.

Build OpenJDK as per the book; Nothing special for 32 bit (except tests have more failures than for 64 bit). Once you have built it: if you want to generate the 32 bit binary:

  • change the name of the jvm directory to OpenJDK-11.0.2+9-i686-bin
  • remove all the *.debuginfo files
  • tar cfJ OpenJDK-11.0.2+9-i686-bin.tar.xz OpenJDK-11.0.2+9-i686-bin
  • Upload, install to anduin.
  • change the md5sum on the blfs book page...

comment:14 by Pierre Labastie, 4 years ago

I've changed the book at r21064. I've also renamed the 32 bit binary on anduin (so that the link on the java binary page works). If you still want to regenerate the 32 bit binary just replace this file.

comment:15 by Douglas R. Reno, 4 years ago

I got 28 failures on x86_64 and 48 on i686. It seems to be working better as well. Tarring it up and doing some more testing (including my *fixed* Libreoffice patch) and then I'll upload it.

Note: See TracTickets for help on using tickets.