Opened 4 years ago

Closed 4 years ago

#11170 closed defect (worksforme)

YouTube and other WebM users broken

Reported by: Douglas R. Reno Owned by: Douglas R. Reno
Priority: normal Milestone: 8.4
Component: BOOK Version: SVN
Severity: major Keywords:
Cc:

Description

This is due to a change on Google's end preventing it from functioning without a certain set of codecs.

The solution is to upgrade to the following packages:

WebKitGTK+-2.22.2 gst-*-1.14.4 (forthcoming) Epiphany-3.30.1

NOTE: Other browsers may be affected as well, I'll test that.

Change History (13)

comment:1 by Douglas R. Reno, 4 years ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:2 by Bruce Dubbs, 4 years ago

YouTube seems to work fine with FF 57.0.4.

comment:3 by Douglas R. Reno, 4 years ago

My guess is that it has to do with gst*'s webm plugin then.

With that logic, shouldn't Falkon be affected (Ken?)

comment:4 by ken@…, 4 years ago

A quick test on falkon seems fine. Same with firefox-62.0.

But youtube are known for rolling out new codecs and gradually converting things to use them. Do you have a URL you can share for a problematic video, or is it general ?

comment:5 by ken@…, 4 years ago

Further thought: I don't think falkon uses gstreamer. The av libs linked to it seem to be:

libwebpmux.so.3 => /usr/lib/libwebpmux.so.3 (0x00007f7a2b99d000) libwebpdemux.so.2 => /usr/lib/libwebpdemux.so.2 (0x00007f7a2b997000) libwebp.so.7 => /usr/lib/libwebp.so.7 (0x00007f7a2b92d000) libasound.so.2 => /usr/lib/libasound.so.2 (0x00007f7a2b7a4000) libvpx.so.5 => /usr/lib/libvpx.so.5 (0x00007f7a2b5c2000) libopus.so.0 => /usr/lib/libopus.so.0 (0x00007f7a2b573000)

I can remember I had to add libopus a while ago, because some clips I downloaded with youtube-dl failed. Hmm, just tried a short dl, it came out as webm but semes to be silent. Mediainfo says it is VP9 and Opus. Hmm, correction - it plays ok in ffplay, xine, parole. But in vlc-3.0.3 it is silent. I doubt I've ever tried to play a webm download in vlc.

comment:6 by Douglas R. Reno, 4 years ago

I think Falkon does use gstreamer, as Qt uses it for the QtMultimedia libraries - but that dependency in Qt5 could be out of date too, I haven't done much investigation.

comment:7 by Xi Ruoyao, 4 years ago

A note from webkitgtk+-2.22.2 release note:

Several fixes for video playback with media source extensions (MSE). This allows using WebM ?support for YouTube, which no longer works through regular video source. Note that MSE is still disabled by default and webkit_settings_set_enable_mediasource() has to be used to enable the feature.

But my epiphany-3.28.3.1 with webkitgtk+-2.20.5 just plays several videos on YouTube fine.

Last edited 4 years ago by Xi Ruoyao (previous) (diff)

comment:8 by Douglas R. Reno, 4 years ago

Try playing videos above 720p. I verified it this morning using Epiphany-3.28.3.1 and WebkitGTK+-2.20.5 too - I couldn't get above 720p (which was choppy), 360p being the only time it was smooth.

When you try to go higher, you get a YouTube help page saying that the browser doesn't support a multimedia codec that's required for HD.

comment:9 by Xi Ruoyao, 4 years ago

I just built webkitgtk+-2.22.2, libdazzle-3.30.1 and then epiphany-3.30.1. Then I can view 1080p videos on YouTube smoothly with epiphany.

My gst-* is still 1.14.2.

comment:10 by Douglas R. Reno, 4 years ago

Thanks for the heads up, I'll make sure that I mention this in the epiphany update! Thank you!

comment:11 by Douglas R. Reno, 4 years ago

The new version of GST has come out!

I'm currently rebuilding my development system and picking up package updates as I go along. I'll close this when Epiphany is done.

comment:12 by Douglas R. Reno, 4 years ago

For progress on this ticket -

I'm doing final verification, and then I'll close it if all is well.

comment:13 by Douglas R. Reno, 4 years ago

Resolution: worksforme
Status: assignedclosed

With the following packages/versions, I can confirm that no breakage is present anymore:

Firefox-64.0.2
FFMPEG-4.1
libwebp-1.0.1
Seamonkey-2.49.4
libvpx-1.7.0
Frameworks-5.53.0
Falkon-3.0.1
Phonon-4.10.1
Qt/QtWebEngine-5.12.0
Epiphany-3.30.2
WebKitGTK+-2.22.5
gst-*-1.14.4
Note: See TracTickets for help on using tickets.