Opened 3 years ago

Closed 3 years ago

#11383 closed defect (fixed)

Fix breakage from poppler-0.70.0 and 0.71.0.

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 8.4
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

As with almost all recent versions of poppler, things changed in both 0.70.0 and 0.71.0 and broke packages which are perhaps using things that poppler's maintainer regards as internal. The following are known to be affected:

cups-filters inkscape libreoffice

A lot of the change can be regarded as continuing churn in poppler. At the moment, Arch seem to be on top of the situation so just use whatever they are using (e.g. for inkscape a patch re 0.70.0 which is actually a series of patches from upstream, and then a sed for 0.71.0).

It doesn't see worth wasting time creating a single patch for this, or using similar seds to replace some of the other patches, when things will probably break again in the next poppler release.

Change History (3)

comment:1 by ken@…, 3 years ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:2 by ken@…, 3 years ago

The inkscape patches are upstream (I see now that what I had originally used for 64+ needs to be combined with later additions), so now naming as 'upstream' and resetting the version to -1.

For cups-filters, this replaces what I needed to use with poppler-0.70.0.

For libreoffice, the patch for 70 looks sane, but without spending a lot of time reviewing the patch for 71 I'm unsure if it is just a hack which migh do the wrong thing with earlier versions (I reiterate that using both works fine with system poppler 71).

comment:3 by ken@…, 3 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.