Opened 3 years ago

Closed 3 years ago

#11437 closed enhancement (fixed)

qt-5.11.3 and qtwebengine-5.11.3.

Reported by: ken@… Owned by: ken@…
Priority: high Milestone: 8.4
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Whilst qt-5.12.0 is intended to be the next long-term stable release of Qt, and to be binary compatible, the secret to compiling qtwebengine-5.12.0 on recent linux is not yet understood.

So far, only Arch (AUR) claim to be able to build it, and trying to run qtwebengine-5.11.2 on qt-5.12.0 does not work (falkon crashes).

I note that fedora, for whatever reason, have moved to 5.11.3 instead of 5.12.0. There are various qtwebengine CVE fixes in 5.11.3 : I'm sure 5.12.0 has these, and maybe more, but there the documentation refers to updates to particular chromium versions instead of CVEs.

To keep falkon users as secure as possible, update Qt5 and qtwebengine to 5.11.3 as a temporary step until 5.12.0 builds.

Change History (3)

comment:1 by ken@…, 3 years ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:2 by ken@…, 3 years ago

Confirmed that falkon works after upgrading only qtwebengine and keeping qt itself at 5.11.2.

comment:3 by ken@…, 3 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.