Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11923 closed enhancement (fixed)

libreoffice: review OpenGL dependencies

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 9.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

While preparing to add GLEW to the book, I noticed that it is listed as optional for libreoffice. Now that I have time to look at that page, I eventually noticed that ogl-math - OpenGL Mathematics (GLM) was also listed, with a link to a rather old version of GLM at sourceforge.

But looking at a log from 6.2.1.2 I cannot find any reference to GLEW or glew, nor in the configure script which is invoked by autogen.sh, so I propose to remove that reference.

For glm, my log say:

checking which glm to use... internal

There is an option, '--with-system-glm', now that GLM is in the book, it should probably be recommended like the other "maybe old version" packages. The "internal" version actually lives in an /UnpackedTarball/glm directory, so it gets downloaded and my logs shows a git version (well, they all have git versions) bae83fa5dc7f081768daace6e199adc3-glm-0.9.4.6-libreoffice.zip.

In theory, a current version should just drop in. But this is libreoffice, so that needs to be tested.

Change History (3)

comment:1 by ken@…, 3 years ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:2 by ken@…, 3 years ago

Resolution: fixed
Status: assignedclosed

Built fine, works for my usage. Fixed in r21445.

comment:3 by Bruce Dubbs, 3 years ago

Milestone: 8.59.0

Milestone renamed

Note: See TracTickets for help on using tickets.