Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#12055 closed enhancement (fixed)

librsvg-2.44.14

Reported by: Douglas R. Reno Owned by: blfs-book
Priority: normal Milestone: 9.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

News
====

- Fix #425 - Don't fail parsing if the system's locale is broken (Paolo Borelli).
- Fix #438, #443 - Don't create intermediate raster surfaces unless
  absolutely needed.  This was causing blurred output for SVGs from
  Inkscape and Illustrator, since they include an "enable-background"
  property even when there are no filters in use.  Thanks to Julian
  Sparber, Jordan Petridis, Zeeshan Ali for doing a huge "git bisect"
  to find the cause of this bug.
- Fix #443 - Fix blurry output when enable-background is used without filters.
- Fix #455 - Fix rounding error on i386 (Olivier Tilloy).
- Check for Cairo errors when constructing paths.

Change History (2)

comment:1 by Bruce Dubbs, 2 years ago

Resolution: fixed
Status: newclosed

Fixed at revision 21592.

Note that there are a lot of failures in the test suite. The results have been reported upstream.

comment:2 by Bruce Dubbs, 2 years ago

Milestone: 8.59.0

Milestone renamed

Note: See TracTickets for help on using tickets.