Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#12143 closed enhancement (fixed)

firefox-67.0.2

Reported by: Douglas R. Reno Owned by: ken@…
Priority: normal Milestone: 9.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

Change History (8)

comment:1 by ken@…, 2 years ago

Owner: changed from blfs-book to ken@…
Status: newassigned

Release notes now at https://www.mozilla.org/en-US/firefox/67.0.2/releasenotes/

inter-alia:

    Fix JavaScript error ("TypeError: data is null in PrivacyFilter.jsm") in console which may significantly degrade sessionstore reliability and performance (bug 1553413)

    Proxy authentication dialog box repeatedly pops up asking to authenticate after upgrading to Firefox 67 (bug 1548804)

    Pearson MyCloud breaks if FIDO U2F is not Chrome's implementation (bug 1551282)

    Starting in safe mode on Linux or macOS causes Firefox to think on the subsequent launch that the profile is too recent to be used with this version of Firefox (bug 1556612)

    Linux distribution users can't easily install/use additional/different languages using the built-in preferences UI (bug 1554744)

    Custom home page is broken with clearing data on shutdown settings applied (bug 1554167)

    Performance-regression for eclipse RAP based applications (bug 1555962)

    Can't start two downloads in parallel via <a download> anymore (bug 1542912)

comment:2 by ken@…, 2 years ago

Reminder to self for the future: Security advisories seem to no-longer get linked from the release notes. For 67.0.2 there is an advisory, but only for windows.

comment:3 by Douglas R. Reno, 2 years ago

Ken, do you know if this fixes the rampant tab-crashing issue? It's happening on both Linux and Windows, but anytime I leave a tab alone for 15 minutes I'll go back to it and it will say that it crashed and offer to restore it.

Seeing as it affects both Windows and Linux, I'm inclined to think that it isn't system-harfbuzz like it was previously

in reply to:  3 comment:4 by ken@…, 2 years ago

Replying to renodr:

Ken, do you know if this fixes the rampant tab-crashing issue? It's happening on both Linux and Windows, but anytime I leave a tab alone for 15 minutes I'll go back to it and it will say that it crashed and offer to restore it.

Seeing as it affects both Windows and Linux, I'm inclined to think that it isn't system-harfbuzz like it was previously

No idea - I occasionally see a tab crashing, but less than once a week (mostly I'm using one desktop and the laptop). I do seem to remember cases where a tab crashed several times and I probably closed it, but not recently.

comment:5 by Douglas R. Reno, 2 years ago

http://linuxfromscratch.org/~renodr/TabCrashFirefox.png

If it helps in the future (since I know Trac has an indexer), this is what happens.

This was on a tab that I leave open for ftp.gnome.org to fetch release notes for GNOME packages. I left it alone for a day, and tabbed back over to verify that I had the right ones for glib-2.60.4, and found that the tab had crashed

comment:6 by ken@…, 2 years ago

Using rustc-1.35.0 and harfbuzz-2.5.0 plus the patch, 67.0.2 builds and seems to work (the patched version also works with an earlier harfbuzz and rustc-1.32.0, gcc-8.3.0 on an alsa build.

comment:7 by ken@…, 2 years ago

Resolution: fixed
Status: assignedclosed

comment:8 by Bruce Dubbs, 2 years ago

Milestone: 8.59.0

Milestone renamed

Note: See TracTickets for help on using tickets.