Opened 2 years ago

Closed 2 years ago

#12286 closed defect (fixed)

firefox 68.0{,.1} i686 needs a patch to compile

Reported by: tnut Owned by: Douglas R. Reno
Priority: normal Milestone: 9.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Following patch https://bugs.chromium.org/p/skia/issues/detail?id=9202 should be apply when compiling on 32 bits machines

Change History (6)

comment:1 by Douglas R. Reno, 2 years ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

Hi tnut, did you manage to bypass the rust error that causes compilation to fail due to not being able to allocate enough RAM? Even with swap, it seems to refuse to use it.

Either way though, I can add a patch for this.

comment:2 by Douglas R. Reno, 2 years ago

I think a sed might be more appropriate though, with a case statement wrapping it:

case $(uname -m) in

i?86) sed -i ...

esac

comment:3 by Douglas R. Reno, 2 years ago

Type: enhancementdefect

Triaging: move to Defect.

comment:4 by tnut, 2 years ago

to avoid the memory problem, you should add in your mozconfig:

ac_add_options --disable-debug-symbols

This Apply to Thunderbird as well.

I aggree for the sed, nevertheless here is the patch I did use:

https://github.com/NuTyX/packages-i686/blob/rolling/gui-extra/firefox/firefox-68.0.1-skcms-1.patch

comment:5 by Douglas R. Reno, 2 years ago

Now that 68.0.2 is out, I'll test it with that version before committing.

Here's what I have so far:

Add a commented "ac_add_options --disable-debug-symbols" to mozconfig, otherwise gkrust will fail to link (llvm complains about being out of memory). Description for that will be something like "If you are compiling on i686, gkrust will fail to link due to memory limits. To fix this, disable debug symbols by uncommenting the line below."

Add a sed command to fix an internal compiler error caused by inlining functions on GCC-7 and later:

sed -i "562 s/mips64/i386/" gfx/skia/skia/third_party/skcms/src/Transform_inl.h

These two allowed a build of 68.0.1 to pass for me last night.

comment:6 by Douglas R. Reno, 2 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r21978

Note: See TracTickets for help on using tickets.