#12558 closed enhancement (fixed)

wireshark-3.0.5

Reported by: Douglas R. Reno Owned by: Bruce Dubbs
Priority: normal Milestone: 9.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

Change History (3)

comment:1 by Bruce Dubbs, 22 months ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Bruce Dubbs, 22 months ago

Wireshark 3.0.5 Release Notes

What’s New

The Windows installers now ship with Qt 5.12.5. They previously shipped with Qt 5.12.4.

If you have Npcap 0.994 or 0.995 installed, your system might crash when upgrading. We recommend that you uninstall these versions manually prior to installing Wireshark. See Npcap bugs 1591[1] and 1675[2] for more details. You can uninstall either version manually by doing the following:

  1. Open a command or PowerShell prompt as Administrator and run sc.exe config npcap start=disabled.
  1. Run sc.exe config npf start=disabled. This will fail if WinPcap compatibility mode isn’t enabled, but is otherwise harmless.
  1. Reboot (optional).
  1. Open “Programs and Features” in the Control Panel or “Apps & features” in Settings and uninstall Npcap.
  1. Open “Device Manager” (devmgmt.msc) in the Control Panel and expand the “Network adapters” section. Uninstall each “Npcap Loopback Adapter” that you find.

Bug Fixes

The following vulnerabilities have been fixed:

The following bugs have been fixed:

  • Qt interface crashes on a profile with packet list only.
  • Wireshark 3.0.4 does not start on macOS 10.13 after an upgrade from 3.0.3.
  • NET-SNMP EngineID Length handling Warning.
  • Upgrade from Wireshark 3.0.2/3.0.3 to 3.0.4/later is confusing and may not complete properly.
  • Crash SIGSEGV when decrypting IEEE 802.11 EAP re-authentications.

comment:3 by Bruce Dubbs, 22 months ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 22186.

Note: See TracTickets for help on using tickets.