#12676 closed enhancement (fixed)

gnutls-3.6.10

Reported by: Bruce Dubbs Owned by: Bruce Dubbs
Priority: normal Milestone: 9.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by Bruce Dubbs, 22 months ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Bruce Dubbs, 22 months ago

Version 3.6.10 (released 2019-09-29)

  • libgnutls: Added support for deterministic ECDSA/DSA (RFC6979) Deterministic signing can be enabled by setting GNUTLS_PRIVKEY_FLAG_REPRODUCIBLE when calling gnutls_privkey_sign_*() functions
  • libgnutls: add gnutls_aead_cipher_encryptv2 and gnutls_aead_cipher_decryptv2 functions that will perform in-place encryption/decryption on data buffers
  • libgnutls: Corrected issue in gnutls_session_get_data2() which could fail under TLS1.3, if a timeout callback was not set using gnutls_transport_set_pull_timeout_function()
  • libgnutls: added interoperability tests with gnutls 2.12.x; addressed issue with large record handling due to random padding
  • libgnutls: the server now selects the highest TLS protocol version, if TLS 1.3 is enabled and the client advertises an older protocol version first
  • libgnutls: fix non-PIC assembly on i386
  • libgnutls: added support for GOST 28147-89 cipher in CNT (GOST counter) mode and MAC generation based on GOST 28147-89 (IMIT). For description of the modes see RFC 5830. S-Box is id-tc26-gost-28147-param-Z (TC26Z) defined in RFC 7836.
  • certtool: when outputting an encrypted private key do not insert the textual description of it. This fixes a regression since 3.6.5
  • API and ABI modifications:
    • gnutls_aead_cipher_encryptv2: Added
    • gnutls_aead_cipher_decryptv2: Added
    • GNUTLS_CIPHER_GOST28147_TC26Z_CNT: Added
    • GNUTLS_MAC_GOST28147_TC26Z_IMIT: Added

comment:3 by Bruce Dubbs, 22 months ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 22299.

Note: See TracTickets for help on using tickets.