#12702 closed enhancement (fixed)

sudo-1.8.29

Reported by: Douglas R. Reno Owned by: Tim Tassonis
Priority: normal Milestone: 9.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

Don't we love regressions? :)

Change History (2)

comment:1 by Tim Tassonis, 21 months ago

Owner: changed from blfs-book to Tim Tassonis
Status: newassigned

Major changes between version 1.8.29 and 1.8.28p1:

The cvtsudoers command will now reject non-LDIF input when converting from LDIF format to sudoers or JSON formats.

The new log_allowed and log_denied sudoers settings make it possible to disable logging and auditing of allowed and/or denied commands.

The umask is now handled differently on systems with PAM or login.conf. If the umask is explicitly set in sudoers, that value is used regardless of what PAM or login.conf may specify. However, if the umask is not explicitly set in sudoers, PAM or login.conf may now override the default sudoers umask. Bug #900.

For make install, the sudoers file is no longer checked for syntax errors when DESTDIR is set. The default sudoers file includes the contents of /etc/sudoers.d which may not be readable as non-root. Bug #902.

Sudo now sets most resource limits to their maximum value to avoid problems caused by insufficient resources, such as an inability to allocate memory or open files and pipes.

Fixed a regression introduced in sudo 1.8.28 where sudo would refuse to run if the parent process was not associated with a session. This was due to sudo passing a session ID of -1 to the plugin.

comment:2 by Tim Tassonis, 21 months ago

Resolution: fixed
Status: assignedclosed

Fixed in revision 22323

Note: See TracTickets for help on using tickets.