#12762 closed enhancement (fixed)

dhcpcd-8.1.2

Reported by: Tim Tassonis Owned by: blfs-book
Priority: normal Milestone: 9.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

dhcpcd-8.1.2 has been released with the following changes:

  • hooks: STOPPED is now run on timeout and exit
  • musl: Fix build
  • Linux: Validate RTM_NEWADDR/RTM_DELADDR messages
  • BSD: Use IP_REVCIF rather than IN_PKTINFO
  • build: address sanitisation is enabled for debug builds
  • build: Improve detection of dlsym requirements
  • DHCP: When rebinding, ensure we have a DHCP ARP state
  • RA: Sort routers when reachability changes
  • RA: Apply hoplimit, reachable and retrans timer values to kernel
  • RA: Warn if advertised MTU > interface MTU
  • OpenBSD: Fix carrier detection for OpenBSD-6.6
  • dhcpcd: Report SSID connection to when we gain carrier
  • DHCP: Fix corruption of address flags when renewing

The last issue was the cause of the recent report about dhcpcd pegging a CPU, so this is quite an important upgrade from 8.1.1

Change History (1)

comment:1 by Tim Tassonis, 21 months ago

Resolution: fixed
Status: newclosed

Fixed in revision 22376.

Note: See TracTickets for help on using tickets.