#12812 closed enhancement (fixed)

gjs-1.58.3

Reported by: Douglas R. Reno Owned by: Douglas R. Reno
Priority: normal Milestone: 9.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

News
====

- Closed bugs and merge requests:
  * GObject based class initialization checks [Marco Trevisan, Philip Chimento,
    !336]
  * Silently leaked return value of callbacks [Xavier Claessens, Philip
    Chimento, #86, !44]
  * Crash when calling Gio.Initable.async_init with not vfunc_async_init
    implementation [Philip Chimento, #287, !362]
  * [cairo] insufficient checking [Philip Chimento, #49, !360]

- Various crash fixes backported from the development branch that didn't close
  a bug or merge request.

Change History (4)

comment:1 by Douglas R. Reno, 20 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:2 by Douglas R. Reno, 20 months ago

Now 1.58.3 :)

News
====

- Emergency release, intended to correct two mistakes in 1.58.2, both coming
  from crash fixes that had unexpected other effects on working code.
  Distributors shipping 1.58.2 are urged to update to 1.58.3 as soon as
  possible.

- Closed bugs and merge requests:
  * possible regression in gjs 1.58.2 [Philip Chimento, #288]
  * JS ERROR: TypeError: this._rooms.get(...) is undefined [Philip Chimento,
    #289, !366]

comment:3 by Bruce Dubbs, 20 months ago

Summary: gjs-1.58.2gjs-1.58.3

comment:4 by Douglas R. Reno, 20 months ago

Resolution: fixed
Status: assignedclosed

Fixed at r22401

Note: See TracTickets for help on using tickets.