#12841 closed defect (fixed)

libreoffice is broken by icu-65.1

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 9.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

One of the packages downloaded and built by libreoffice is libfreehand-0.1.2. With icu-65.1 that no longer compiles (libfreehand_utils.cpp needs a semicolon at the end of line 165). The same version was ok with icu-64.

Libfreehand seems to be a package of little use to most people, but it either has to be built-in or else LO needs the system version. Looking at Arch, the system version needs librevenge which LO also ships.

I'm trying a build without system-icu, but the first attempt (kernel-5.3.14) locked up a little over half an hour ago.

Change History (2)

comment:1 by ken@…, 20 months ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:2 by ken@…, 20 months ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.