#12852 closed enhancement (fixed)

iptables-1.8.4

Reported by: Bruce Dubbs Owned by: thomas
Priority: normal Milestone: 9.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (4)

comment:1 by thomas, 20 months ago

https://netfilter.org/projects/iptables/files/changes-iptables-1.8.4.txt

Btw, in opposite to what we have in book, there seems to be something like a test suite:

$ sudo ./iptables-test.py

Unfortunatly, when running it just as it is, i got lots of errors and the result is

107 test files, 803 unit tests, 407 passed

The script does not run too long, 0.1 SBU i think.

Any ideas on how to invoke that test script to report a better result than 50% failures? (I've mailed to Shekhar but do not expect a reply quickly)

Last edited 20 months ago by thomas (previous) (diff)

comment:2 by thomas, 20 months ago

Owner: changed from blfs-book to thomas
Status: newassigned

comment:3 by thomas, 20 months ago

Got response from Shekhar:

Hi Thomas!

First of all thanks for reaching out and sorry for my delayed response
as i was a little busy with my semester exams.

When checked the iptables-test.py file after your mail, i also had the
same error.
But might i suggest the following:
These errors might be generated because you must be using/testing nftables also
on the same machine. The results may significantly improve if you do:

./configure --disable-nftables
make
make install
sudo python3 iptables-test.py

This worked on my machine, except 3-4 (99.5% success) tests failing.
Will let you know more
about it once i figure out how to get full 100% tests passed.

Kindly feel free to contact me any time if i can contribute in any way to the
Linux from Scratch project.

Thanks!
Shekhar Sharma

So i have to recheck if --disable-nftables was really set, but i'm pretty sure as i used the commands from the book.

If ok, i'd go to upgrade iptables to 1.8.4 anyway, leaving the test suite out for now and do some investigations independently.

comment:4 by thomas, 20 months ago

Resolution: fixed
Status: assignedclosed

Fixed in r22451

Note: See TracTickets for help on using tickets.