Opened 3 years ago

Closed 3 years ago

#12961 closed enhancement (fixed)

libva-2.6.0

Reported by: Bruce Dubbs Owned by: Pierre Labastie
Priority: normal Milestone: 9.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version.

Change History (7)

comment:1 by Pierre Labastie, 3 years ago

Owner: changed from blfs-book to Pierre Labastie
Status: newassigned

comment:2 by Pierre Labastie, 3 years ago

Key Improvement

    enable the mutiple driver selection logic and enable it for DRM.
    drm: Add iHD to driver_name_map
    Add missed slice parameter 'slice_data_num_emu_prevn_bytes'
    ensure that all meson files are part of the release tarball
    configure: use correct comparison operator
    trace: support VAConfigAttribMultipleFrame in trace
    remove incorrect field of VAConfigAttribValDecJPEG
    va/va_trace: Dump VP9 parameters for profile 1~3
    add multiple frame capability report
    add variable to indicate layer infromation
    trace: fix memory leak on closing the trace
    add prediction direction caps report
    Add comments for colour primaries and transfer characteristics in VAProcColorProperties

Known issue

#355 which can be fixed by #356

Maybe wait for next version or apply the fix: the issue is annoying (no way to force i965 on X11)

comment:3 by Bruce Dubbs, 3 years ago

Have you tried that patch? If it works we probably should add it. We don't know when a new release will be made. The previous release was in July and we have about six weeks until we start tagging for 9.1.

comment:4 by Pierre Labastie, 3 years ago

Well, their issue #354 tells they might release 2.6.1 soon. Note that the patch is said to work by their reviewer. I propose to wait until January 1st. If nothing has come, I'll put the new version and the patch into the book.

comment:5 by Pierre Labastie, 3 years ago

Actually, looking more closely at the patch, it seems to me that there is an error (freeing a NULL pointer). I've reported to their issue #356.

comment:6 by Pierre Labastie, 3 years ago

To try upstream issue #355, I need an alternate driver for intel graphics. Problem is the iHD driver is only available on 5th gen and later, and I have only a Haswell (4th gen)... So I'll put the patch and the new version in the book, and ask for testing on the list...

Last edited 3 years ago by Pierre Labastie (previous) (diff)

comment:7 by Pierre Labastie, 3 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r22532

Note: See TracTickets for help on using tickets.