Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#13023 closed enhancement (overcomebyevents)

pipewire-0.3.1

Reported by: Bruce Dubbs Owned by: Bruce Dubbs
Priority: normal Milestone: 10.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description (last modified by Bruce Dubbs)

Need to check on this. It may be a development release.

Now version 0.3.0 stable.

Change History (13)

comment:1 by Douglas R. Reno, 3 years ago

This seems to be a normal release based off the changes in https://github.com/PipeWire/pipewire/releases

comment:2 by Bruce Dubbs, 3 years ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:3 by Bruce Dubbs, 3 years ago

Milestone: 9.1hold
Summary: pipewire-0.2.90pipewire-0.2.90 (Wait for plasma and/or mutter to need this)

The NEWS file for this release says:

"PipeWire 0.3.0

This is the first release of the 0.3 version. It consists of a major rewrite and is not API or ABI compatible with the 0.2 branch."

The only packages that use this are plasma and mutter. I am moving this to hold until these packages use this newer version and probably until version 0.3.0 is released.

comment:4 by Douglas R. Reno, 3 years ago

Now 0.2.92

I'm glad we decided to hold. If you look at the releases portion of Github, you'll see lots of extra changes over the past two days. I definitely think this is a good move.

comment:5 by Bruce Dubbs, 3 years ago

Description: modified (diff)
Summary: pipewire-0.2.90 (Wait for plasma and/or mutter to need this)pipewire-0.3.0 (Wait for plasma and/or mutter to need this)

comment:6 by Xi Ruoyao, 3 years ago

Milestone: hold9.2

mutter-3.36.0 needs this.

comment:7 by Xi Ruoyao, 3 years ago

Summary: pipewire-0.3.0 (Wait for plasma and/or mutter to need this)pipewire-0.3.1

Now 0.3.1.

comment:8 by Xi Ruoyao, 3 years ago

Meson command:

meson --prefix /usr --sysconfdir /etc -D{pipewire-,}jack=false -Dvulkan=false

comment:9 by Xi Ruoyao, 3 years ago

It can be installed along with pipewire-0.2.x w/o conflict.

comment:10 by Bruce Dubbs, 3 years ago

It appears that the only package in plasma that needs this is xdg-desktop-portal-kde and the current package in the book is OK with version 0.3 (or version 0.2).

The current version of mutter just says >= 0.2.5, so it is unclear of 0.3 is OK. We should probably do mutter 3.36 and pipewire-0.3 at the same time.

comment:11 by Bruce Dubbs, 3 years ago

Resolution: overcomebyevents
Status: assignedclosed

Moving to ticket #13244 so it will be updated when mutter is updated.

comment:12 by Bruce Dubbs, 2 years ago

Milestone: 9.210,0

Milestone renamed

comment:13 by Bruce Dubbs, 2 years ago

Milestone: 10,010.0

Milestone renamed

Note: See TracTickets for help on using tickets.