Opened 16 months ago

Closed 16 months ago

Last modified 15 months ago

#13657 closed enhancement (fixed)

alsa-lib alsa-utils 1.2.3

Reported by: Bruce Dubbs Owned by: Douglas R. Reno
Priority: normal Milestone: 10.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (6)

comment:1 by Douglas R. Reno, 16 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:2 by Douglas R. Reno, 16 months ago

alsa-lib

Core

    Release v1.2.3
    snd_dlopen: implement the relocatable version for glibc
    github actions: ubuntu - fix the non-interactive build
    pcm: dmix: assembly: fix the interface for safety (mmx)
    configure: add --embed for python3-config (python 3.8)

Config API

    conf: add snd_config_is_array() function

Control API

    tlv: implement nearest rounding in snd_tlv_convert_from_dB() for xdir == 0
    control: use more precise rounding in snd_ctl_ascii_value_parse()
    snd_dlopen: do not use absolute plugin path for snd_dlopen() calls
    namehint: remember the direction from the upper levels
    conf: namehint - add omit_noargs to the hint section

Mixer API

    tlv: implement nearest rounding in snd_tlv_convert_from_dB() for xdir == 0
    snd_dlopen: do not use absolute plugin path for snd_dlopen() calls

PCM API

    pcm: Fix memory leak at snd_pcm_new when THREAD_SAVE_API is defined
    pcm: clarify -ENODATA description (recovery, event)
    pcm: fix spelling in documentation for -EBADFD
    pcm: add documentation for -ENODATA error code
    snd_dlopen: do not use absolute plugin path for snd_dlopen() calls
    pcm: return immediately when the state is SETUP in snd_pcm_drain()
    pcm: fix snd_pcm_drain() excluding SETUP state from valid states
    pcm: rate: Fix uninitialized variable warning
    pcm: rate: Fix compile warning wrt bit ops and comparison
    pcm: dmix: assembly: give more freedom over the constraints
    pcm: dmix: assembly: refactor the PIC mode
    pcm: dmix: assembly: fix the interface for safety (mmx)
    pcm: dmix: assembly: fix the interface for safety
    pcm: dmix: assembly: change the token by symbolic names
    fix infinite draining of the rate plugin in SND_PCM_NONBLOCK mode
    pcm: rate - fix the remaining size calculation in snd_pcm_rate_drain()
    pcm: dmix: fix sw_params handling of timestamp types in direct plugins
    pcm: add chmap option to route plugin

Topology API

    topology: Add missing ATTRIBUTE_UNUSED
    topology: use snd_config_is_array() function
    topology: Use bool parser to parse boolean value
    topology: add back asrc to widget_map in dapm.c

Use Case Manager API

    ucm: fix the wrong return value in uc_mgr_open_ctl()
    ucm: remove strict: in ${OpenName} substitution
    ucm: fix the error path in parse_toplevel_path()
    ucm: fix the wrong uc_mgr_open_ctl() call in if_eval_control_exists()
    use-case.h: define Linked variable
    ucm: implement CardIdByName substitution
    ucm: shuffle code in compound_merge()
    ucm: substitute arguments in sequences only for syntax 3+
    ucm: substitute RenameDevice and DeleteDevice lists
    ucm: substitute Comment in Transition and Device
    ucm: substitute verb name and file field
    ucm: substitute component sequence string
    ucm: substitute device strings in the device lists
    ucm: substitute device / modifier names, too
    ucm: implement the toplevel ucm configuration file parser
    ucm: substitute ${CardNumber}
    ucm: substitute ${OpenName}
    ucm: Define/DefineRegex is supported in Syntax 3
    ucm: String condition - implement Empty
    ucm: handle strict: prefix correctly for the UCM card name
    ucm: substitute also value strings
    ucm: allow to specify the toplevel directory using '/' as first character in File path
    ucm: config - change the in-place include evaluation order
    ucm: allow syntax version 3
    ucm: substitute arguments in sequences
    ucm: configuration - add DefineRegex
    ucm: configuration - allow to define the configuration variables
    ucm: config - substitute File string to allow variables in include
    ucm: configuration - substitute ${ConfDir} and ${ConfTopDir}
    ucm: configuration - implement in-place Include
    ucm: rename _once command to _boot command
    ucm: rename SectionOnce to BootSequence
    ucm: fix compilation error in set_defaults_user()
    ucm: fix SectionOnce comment
    ucm: initialize mgr->once_list
    ucm: handle 'set _defaults' command
    ucm: handle 'set _once' command
    ucm: execute SectionDefaults lately (when the first verb is set)
    ucm: parse SectionOnce section in the master UCM configuration file
    ucm: merge the array items from the condition blocks
    use-case.h: add USB as allowed device name
    ucm: fix copy-n-paste typo (RemoveDevice list)
    ucm: fix the device remove operation
    usecase: allow indexes also for modifier names
    ucm: fix uc_mgr_scan_master_configs()
    ucm: clarify the index syntax for the device names

Configuration

    conf: USB-Audio: Add HP Thunderbolt Dock in the IEC958 blacklist
    conf: remove debug printf() in snd_config_hook_load()
    conf: add support for XDG_CONFIG_HOME search path
    conf: load function (hook) - add OR support
    conf: USB-Audio.conf - add another card name for Asus Xonar 5
    conf: add snd_config_is_array() function
    conf: use bool type for the join member in the config structure
    conf: change namehint for pcm.front
    conf: USB-Audio: Fix S/PDIF output of ASUS Xonar AE
    pcm: dmix: fix sw_params handling of timestamp types in direct plugins
    conf: fix namehint for pcm.front and pcm.iec958
    conf: USB-Audio: Add C-Media USB Headphone Set to the IEC958 blacklist
    Change PCM device number of Asus Xonar U5
    conf: namehint - add omit_noargs to the hint section
    conf: change the order of PCM devices in alsa.conf

Dynamic Loader helpers

    dlsym: fix the snd_dlopen(), incorrect variable use
    dlsym: fix again snd_dlpath()
    dlsym: fix the reference to the origin lib directory
    snd_dlopen: implement the relocatable version for glibc

Kernel Headers

    header: Fix build error with old kernel headers

Simple Abstraction Mixer Modules

    snd_dlopen: implement the relocatable version for glibc
    snd_dlopen: do not use absolute plugin path for snd_dlopen() calls

Test/Example code

    test: pcm_min - add snd_pcm_drain() call and indentation fixes 

comment:3 by Douglas R. Reno, 16 months ago

alsa-utils

 Core

    Release v1.2.3
    github actions: ubuntu - fix the non-interactive build
    github workflow: fix tag fetch

ALSA Control (alsactl)

    alsactl: ucm - rename _once command to _boot command
    alsactl: allow to compile alsactl without UCM support
    alsactl: use the right priority for syslog messages
    alsactl: add -D argument to execute also the UCM defaults section
    alsactl: redirect alsa-lib errors
    alsactl: add initial support for UCM init
    alsactl: init - iterate through all cards for the initial settings
    alsactl: daemon.c - fix gcc warning in write_pid_file()
    alsactl: fix error handling for sched_setscheduler() call
    alsactl: avoid needless wakeups in monitor loop.
    alsactl: don't exit on EINTR from epoll_wait().

alsa-info.sh

    alsa-info.sh: increase version to 0.4.65
    alsa-info: initial rpm/deb package info
    alsa-info.sh: add ALT to DISTRO list

alsaloop

    alsaloop: reduce cumulative error caused by non-atomic samples calculation

alsamixer

    alsamixer: suppress _XOPEN_SOURCE compile warning

alsaucm

    alsaucm: remove custom rules, alsactl is UCM aware now
    alsactl: ucm - rename _once command to _boot command

amixer

    amixer: retype to double in convert_prange1() like in convert_prange()
    amixer: improve the raw percentual volume rounding 

comment:4 by Douglas R. Reno, 16 months ago

Resolution: fixed
Status: assignedclosed

Fixed at r23274

comment:5 by Bruce Dubbs, 15 months ago

Milestone: 9.210,0

Milestone renamed

comment:6 by Bruce Dubbs, 15 months ago

Milestone: 10,010.0

Milestone renamed

Note: See TracTickets for help on using tickets.