#13952 closed enhancement (fixed)

nasm-2.15.05

Reported by: Douglas R. Reno Owned by: Bruce Dubbs
Priority: normal Milestone: 10.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

Change History (3)

comment:1 by Bruce Dubbs, 11 months ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Bruce Dubbs, 11 months ago

Summary: nasm-2.15.04nasm-2.15.05

Now version 2.15.05.

C.1.1 Version 2.15.05

  • Correct %ifid $ and %ifid $$ being treated as true.
  • Add --reproducible option to suppress NASM version numbers and timestamps in output files.

C.1.2 Version 2.15.04

  • More sensible handling of the case where one single-line macro definition will shadow another. A warning will be issued, but the additional definition will be allowed. For the existing error case where both a parameterless and parametered macro are created, that warning is promoted to an error by default.
  • Add special preprocessor tokens %*? and %*?? that expand like %? and %?? in single-line macros only.
  • Correct the encoding of the ENQCMDS and TILELOADT1 instructions.
  • Fix case where the COFF backend (the coff, win32 and win64 output formats) would add padding bytes in the middle of a section if a SECTION/SEGMENT directive was provided which repeated an ALIGN= attribute. This neither matched legacy behavior, other backends, or user expectations.
  • Fix SSE instructions not being recognized with an explicit memory operation size (e.g. movsd qword [eax],xmm0).
  • The -L+ option no longer enables -Lw, which is mainly useful to debug NASM crashes.
  • Document long-standing hazards in the use of $ in Dx statements.
  • The NASM-only RDOFF output format backend, which has been broken since at least NASM 2.14, has been disabled. The RDOFF tools are scheduled to be removed from the NASM distribution in NASM 2.16. If you have a concrete use case for RDOFF, please file a NASM bug report at https://bugs.nasm.us/ as soon as possible.

comment:3 by Bruce Dubbs, 11 months ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 23674.

Note: See TracTickets for help on using tickets.