#14096 closed enhancement (fixed)

libcap-2.44 (wait for lfs)

Reported by: Bruce Dubbs Owned by: Bruce Dubbs
Priority: normal Milestone: 10.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New miinor version.

Change History (3)

comment:1 by Bruce Dubbs, 10 months ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Bruce Dubbs, 10 months ago

Release notes for 2.44 2020-10-04 18:43:17 -0700

Generally, this is a release to help package builders: no functional change to any of the generated code just documentation and make related fixes.

  • 2.43 was a regression for cross-compilation purposes. Two patches address this.
  • Recent golang builds (pre-release) default to ignoring GOPATH, so adjust the in-tree building to override this explicitly with GO111MODULE=off
  • Support testing of a DYNAMIC=yes build with the shared libraries/ This includes only requiring a statically linked version of capsh (tcapsh-static) with sudotest
  • uClibc can also build statically.
  • Support build trees that have no pthreads in the environment
  • Go package document updates since golang 1.15 is released.

comment:3 by Bruce Dubbs, 10 months ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 23812.

Note: See TracTickets for help on using tickets.