Opened 8 months ago

Closed 8 months ago

#14311 closed enhancement (fixed)

php-7.4.13

Reported by: Bruce Dubbs Owned by: Douglas R. Reno
Priority: normal Milestone: 10.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by Douglas R. Reno, 8 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:2 by Douglas R. Reno, 8 months ago

Version 7.4.13
26 Nov 2020

    Core:
        Fixed bug #80280 (ADD_EXTENSION_DEP() fails for ext/standard and ext/date).
        Fixed bug #80258 (Windows Deduplication Enabled, randon permission errors).
    COM:
        Fixed bug #62474 (com_event_sink crashes on certain arguments).
    DOM:
        Fixed bug #80268 (loadHTML() truncates at NUL bytes).
    FFI:
        Fixed bug #79177 (FFI doesn't handle well PHP exceptions within callback).
    IMAP:
        Fixed bug #64076 (imap_sort() does not return FALSE on failure).
        Fixed bug #76618 (segfault on imap_reopen).
        Fixed bug #80239 (imap_rfc822_write_address() leaks memory).
        Fixed minor regression caused by fixing bug #80220.
        Fixed bug #80242 (imap_mail_compose() segfaults for multipart with rfc822).
    MySQLi:
        Fixed bug #79375 (mysqli_store_result does not report error from lock wait timeout).
        Fixed bug #76525 (mysqli::commit does not throw if MYSQLI_REPORT_ERROR enabled and mysqlnd used).
        Fixed bug #72413 (mysqlnd segfault (fetch_row second parameter typemismatch)).
    ODBC:
        Fixed bug #44618 (Fetching may rely on uninitialized data).
    Opcache:
        Fixed bug #79643 (PHP with Opcache crashes when a file with specific name is included).
        Fixed run-time binding of preloaded dynamically declared function.
    OpenSSL:
        Fixed bug #79983 (openssl_encrypt / openssl_decrypt fail with OCB mode).
    PDO MySQL:
        Fixed bug #66528 (No PDOException or errorCode if database becomes unavailable before PDO::commit).
        Fixed bug #65825 (PDOStatement::fetch() does not throw exception on broken server connection).
    SNMP:
        Fixed bug #70461 (disable md5 code when it is not supported in net-snmp).
    Standard:
        Fixed bug #80266 (parse_url silently drops port number 0).

comment:3 by Douglas R. Reno, 8 months ago

Resolution: fixed
Status: assignedclosed

Fixed at r23946

Note: See TracTickets for help on using tickets.