Opened 7 months ago

Closed 6 months ago

#14414 closed enhancement (fixed)

cbindgen-0.16.0 (Wait for TB and FF updates)

Reported by: Bruce Dubbs Owned by: ken@…
Priority: normal Milestone: hold
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New patch version.

Change History (15)

comment:1 by Bruce Dubbs, 7 months ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Douglas R. Reno, 7 months ago

Summary: cbindgen-0.15.2cbindgen-0.16.0

This now seems to be 0.16.0

comment:3 by Bruce Dubbs, 7 months ago

Milestone: 10.1hold
Summary: cbindgen-0.16.0cbindgen-0.16.0 (Wait for TB and FF updates)

This version breaks thunderbird and firefox. These are the only apps that use this package.

Put this in hold until TB and FF release new versions that support it.

comment:4 by ken@…, 7 months ago

https://bugzilla.mozilla.org/show_bug.cgi?id=1684180

Fixed for 78.6.1 by https://hg.mozilla.org/releases/mozilla-esr78/rev/140e5caa92c3 and for 78.7.0 by https://hg.mozilla.org/releases/mozilla-esr78/rev/a1f99bfc3ee5

so we should be good to go when both firefox and thunderbird have released one of those versions.

comment:5 by ken@…, 7 months ago

Firefox was updated to 78.6.1 in r24080.

Still waiting for a thunderbird release of 78.6.1 or 78.7.0.

comment:6 by ken@…, 6 months ago

Thunderbird was updated to 78.6.1 in r24109 so this should be good to go.

in reply to:  6 ; comment:7 by Tim Tassonis, 6 months ago

Replying to ken@…:

Thunderbird was updated to 78.6.1 in r24109 so this should be good to go.

I have compiled firefox 78.6.1 using cbindgen 0.15.0, but was only able to do so using

export CC=clang CXX=clang++ CXXFLAGS="-static-libstdc++"

With g++, I always got cbindgen errors, is that a known issue or did I mess up somewhere else?

in reply to:  7 ; comment:8 by ken@…, 6 months ago

Replying to timtas:

Replying to ken@…:

Thunderbird was updated to 78.6.1 in r24109 so this should be good to go.

I have compiled firefox 78.6.1 using cbindgen 0.15.0, but was only able to do so using

export CC=clang CXX=clang++ CXXFLAGS="-static-libstdc++"

With g++, I always got cbindgen errors, is that a known issue or did I mess up somewhere else?

Looks like a completely new problem. 0.15.0 was fine for me, and I think I successfully ran a build of 78.6.1 with 0.16.0, but did not install. Are you using any of the "extra" options that the book offers ? I don't use any of them. I also normally use -O3 on my development machine, but that doesn't seem to relate to your problem. Any details of the errors ?

comment:9 by ken@…, 6 months ago

Meanwhile, I've successfully built firefox-78.7.0 build candidate 1 with cbindgen-0.16.0 (due out next week, there might be a later candidate that invalidates this build).

Now testing thunderbird 78.6.1 to confirm it builds with cbindgen-0.16.0 (Arch implies it does, but this wouldn't be the first time that something in AUR was broken ;)

in reply to:  9 comment:10 by ken@…, 6 months ago

Replying to ken@…:

Now testing thunderbird 78.6.1 to confirm it builds with cbindgen-0.16.0 (Arch implies it does, but this wouldn't be the first time that something in AUR was broken ;)

Yes, thunderbird-78.6.1 built fine with cbindgen-0.16.0 and rustc-1.47.0.

in reply to:  8 comment:11 by Tim Tassonis, 6 months ago

Replying to ken@…:

Replying to timtas:

Replying to ken@…:

Thunderbird was updated to 78.6.1 in r24109 so this should be good to go.

I have compiled firefox 78.6.1 using cbindgen 0.15.0, but was only able to do so using

export CC=clang CXX=clang++ CXXFLAGS="-static-libstdc++"

With g++, I always got cbindgen errors, is that a known issue or did I mess up somewhere else?

Looks like a completely new problem. 0.15.0 was fine for me, and I think I successfully ran a build of 78.6.1 with 0.16.0, but did not install. Are you using any of the "extra" options that the book offers ? I don't use any of them. I also normally use -O3 on my development machine, but that doesn't seem to relate to your problem. Any details of the errors ?

I got:

 0:09.70 checking for clang for bindgen... not found
 0:09.70 checking for libclang for bindgen... not found
 0:09.70 ERROR: Could not find clang to generate run bindings for C/C++. Please install the necessary packages, run `mach bootstrap`, or use --with-clang-path to give the location of clang.
 0:09.75 *** Fix above errors and then restart with\
 0:09.75                "./mach build"
 0:09.75 make: *** [client.mk:115: configure] Error 1

I have llvm/clang under /opt/llvm11, only enabling it when needed by

pathappend /opt/llvm11/bin

, so maybe this alone is the cause. Will try again with enabling clang, but still using g++

in reply to:  8 comment:12 by Tim Tassonis, 6 months ago

Replying to ken@…:

Replying to timtas:

Replying to ken@…:

Thunderbird was updated to 78.6.1 in r24109 so this should be good to go.

I have compiled firefox 78.6.1 using cbindgen 0.15.0, but was only able to do so using

export CC=clang CXX=clang++ CXXFLAGS="-static-libstdc++"

With g++, I always got cbindgen errors, is that a known issue or did I mess up somewhere else?

Looks like a completely new problem. 0.15.0 was fine for me, and I think I successfully ran a build of 78.6.1 with 0.16.0, but did not install. Are you using any of the "extra" options that the book offers ? I don't use any of them. I also normally use -O3 on my development machine, but that doesn't seem to relate to your problem. Any details of the errors ?

So, it turns out this was all my fault, it builds fine with gcc after calling

pathappend /opt/llvm11/bin

before the build. Sorry for the noise.

comment:13 by ken@…, 6 months ago

Bruce, would you like me to take this ?

comment:14 by ken@…, 6 months ago

Owner: changed from Bruce Dubbs to ken@…
Status: assignednew

comment:15 by ken@…, 6 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.