Opened 6 months ago

Closed 6 months ago

#14573 closed enhancement (fixed)

pangomm-2.46.0

Reported by: Douglas R. Reno Owned by: Douglas R. Reno
Priority: normal Milestone: 10.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version

Similar to glibmm, this seems to be based off the old ABI. It looks like it's primarily documentation fixes, with some fixes to match the Pango API and a couple of new features.

Change History (3)

comment:1 by Douglas R. Reno, 6 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:2 by Douglas R. Reno, 6 months ago

Confirmed that it's the old ABI version

2.46.0 (stable):

The tarball for 2.46.0 has been created with 'meson dist'.
If you build with Autotools from the tarball, please read the relevant
part of the README file.

* Attribute: Add Overline and ShowFlags enums and some create*() methods
  (Kjell Ahlstedt) Issue #9 (misos1)
* Font, FontFace, FontFamily, FontMetrics: Add new methods
  (Kjell Ahlstedt)
* LayoutIter: Fix get_run()
  (Kjell Ahlstedt)
* LayoutRun: Fix a memory leak in split()
  (Kjell Ahlstedt)
* GlyphString, Item: Wrap pango_shape_with_flags()
  (Kjell Ahlstedt) Issue #9 (Tavmjong Bah)
* Layout: Add set/get_line_spacing()
  (Kjell Ahlstedt) Issue #9 (misos1)
* Layout: Add get_const_line() and get_const_lines()
  (Kjell Ahlstedt) Issue #10 (misos1)
* LayoutRun: Make most methods public
  (Kjell Ahlstedt) Issue #11 (Josh Bialkowski)
* Coverage: Deprecate create(bytes, n_bytes), max(), to_bytes()
  (Kjell Ahlstedt)

Build:
* Requires pango >= 1.45.1
  because of Overline
  (Kjell Ahlstedt)

comment:3 by Douglas R. Reno, 6 months ago

Resolution: fixed
Status: assignedclosed

Fixed at r24159

Note: See TracTickets for help on using tickets.