Opened 6 months ago

Closed 6 months ago

#14577 closed enhancement (fixed)

wayland-1.19.0

Reported by: Douglas R. Reno Owned by: Douglas R. Reno
Priority: normal Milestone: 10.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version

Change History (3)

comment:1 by Douglas R. Reno, 6 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:2 by Douglas R. Reno, 6 months ago

There are a lot of changes here:

1.18.91

This is the alpha release for wayland 1.19.

This release mostly contains bug fixes and minor protocol updates.

Full commit history below.

Alyssa Ross (1):
      doc: make reproducible

Christopher James Halse Rogers (1):
      protocol: Minor gramatical fix.

Emmanuel Gil Peyrot (4):
      cursor: Use spaces for alignment in the header
      cursor: Properly document wl_cursor_image and wl_cursor
      doc: Document libwayland-cursor with autotools
      doc: Document libwayland-cursor with meson

Guido Günther (1):
      scanner: Guard interface declarations

Jan Beich (4):
      meson/tests: add missing dependencies on protocol headers
      cursor: posix_fallocate may fail with EINVAL if not supported
      cursor: ignore posix_fallocate in shm_pool_resize if not supported by FS
      cursor/os-compatibility: move resizing into a separate function

Kirill Chibisov (2):
      Clarify the order of wl_keyboard.modifiers
      Clarify clients behavior on wl_keyboard.leave

Matt Turner (5):
      meson: Require wayland-scanner of a matching version
      meson: Add option to control building wayland-scanner
      .gitlab-ci.yml: Switch from Stretch to Buster
      meson: Raise requirement to meson >= 0.52.1
      meson: Deduplicate generation of wayland-version.h

Maxime Roussin-Bélanger (6):
      doc: fix typos
      tests: fix typos
      CONTRIBUTING: fix typo "excercising"
      cursor: fix typo "insufficent"
      egl: fix typo "Backards"
      server: fix typos

Nick Diego Yamane (1):
      protocol: Clarify how clients can cancel a drag operation

Peter Hutterer (4):
      Replace initial 8 spaces with a tab for all xml files
      editorconfig: add settings for the .gitlab-ci.yml file
      gitlab CI: update to use the fdo ci templates
      Add a basic gitlab issue template

Ricardo Quesada (1):
      README with upadated compile instructions

Simon Ser (9):
      build: re-open master for regular development
      protocol: add invalid_size error to wl_surface
      client: improve wl_display_connect docs
      doc/man: remove manually written man pages
      protocol: add seat missing_capability error
      protocol: disambiguate key codes in wl_keyboard.key
      protocol: make it clear wl_surface.enter/leave are not for frame throttling
      protocol: deprecate non-current wl_output.mode
      build: bump to version 1.18.91 for the alpha release

Tomek Bury (1):
      util: fix compiler warning

Valentin (2):
      Use fixed size integer type
      Fix undefined behavior

Yann Dirson (1):
      doc: fix and clarify pointer image behaviour

ganjing (1):
      cursor/convert_font.c: malloc cannot guarantee that the memory allocated is always successful

git tag: 1.18.91

1.18.92

This is the beta release for wayland 1.19.

Full commit history below.

Loïc Yhuel (1):
      meson: link with -lrt if needed for clock_gettime

Simon Ser (2):
      Remove TODO
      build: bump to version 1.18.92 for the beta release

git tag: 1.18.92

1.18.93

This is the RC1 release for wayland 1.19.

Full commit history below.

Loïc Yhuel (1):
      server: Allow absolute paths in WAYLAND_DISPLAY

Simon Ser (2):
      protocol: sync wl_shm.format with libdrm 2.4.104
      build: bump to 1.18.93 for the RC1 release

git tag: 1.18.93

1.19.0

Wayland 1.19.0 is released!

This release mostly contains bug fixes and minor protocol updates.

Commit history since RC1 below (no changes apart from the version
bump).

Simon Ser (1):
      build: bump to version 1.19.0 for the official release

git tag: 1.19.0

comment:3 by Douglas R. Reno, 6 months ago

Resolution: fixed
Status: assignedclosed

Fixed at r24163

Note: See TracTickets for help on using tickets.