Opened 6 months ago

Closed 6 months ago

#14586 closed enhancement (fixed)

libburn libisoburn libisofs 1.5.4

Reported by: Douglas R. Reno Owned by: Douglas R. Reno
Priority: normal Milestone: 10.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point versions

Change History (7)

comment:1 by Douglas R. Reno, 6 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:2 by Douglas R. Reno, 6 months ago

libburn

libburn-1.5.4.tar.gz Sat Jan 30 2021
===============================================================================
* Bug fix: Early SCSI commands from sg-linux.c were not logged
* New API call burn_drive_set_speed_exact()
* New API call burn_nominal_slowdown()

libburn-1.5.2.pl01.tar.gz Mon Nov 25 2019
===============================================================================
* Bug fix: cdrskin multi-track burning was slow and stalled after track 1.
           Regression introduced in version 1.5.0 by commit 84fad99, 2018.02.05
           O_DIRECT is now disabled for track sources.

comment:3 by Douglas R. Reno, 6 months ago

Milestone: 10.1hold
Summary: libburn libisoburn libisofs 1.5.4libburn libisoburn libisofs 1.5.4 (Waiting on the maintainer to release new versions)

I sent the maintainer an email last night about the files not being present on files.libburnia-project.org/releases/. There was a bug in 1.5.4 that could potentially result in lots of bad media. Once those tarballs are available (I'll check daily), I'll move this ticket to 10.1 and begin work on it again.

Hi,

Douglas R. Reno wrote:
> At Linux From Scratch, we're trying to update from
> libburn/libisofs/libisoburn 1.5.2 to 1.5.4, and we're unable to download the
> files from https://files.libburnia-project.org/releases/.

I am hunting a nasty bug which sneaked in about 5 years ago, but was
reported between preparing the release 1.5.4 in the repo and uploading
the library tarballs.
The problem is in libisofs since release 1.4.0. It was detected when
making backups from NFS. But it can happen in any situation where many
large xattr are to be recorded. It causes unreadable filesystems and thus
wasted media. To my luck it is quite noticeable when it happens.

There is already a GNU xorriso-1.5.4 uploaded, which i would like to retire
if that was possible.


> What is the recommended way to get those tarballs?

My plan is to find and fix the cause of the bug and to then produce a
better libisofs-1.5.4 before uploading all three libraries.
GNU xorriso will get a bug-fix version 1.5.4.pl01.

A first fix attempt on monday introduced a new problem. I roughly know
how to avoid that problem, but i don't yet understand fully why this new
fix helps.

It may last a few more days of analysis and thorough testing until i
feel confident enough for uploading.


Have a nice day 

Thomas

comment:4 by Douglas R. Reno, 6 months ago

Milestone: hold10.1
Hi,

Douglas R. Reno wrote:
> At Linux From Scratch, we're trying to update from
> libburn/libisofs/libisoburn 1.5.2 to 1.5.4, and we're unable to download the
> files from https://files.libburnia-project.org/releases/.

It is done now:

  http://files.libburnia-project.org/releases/libburn-1.5.4.tar.gz
  http://files.libburnia-project.org/releases/libisofs-1.5.4.tar.gz
  http://files.libburnia-project.org/releases/libisoburn-1.5.4.tar.gz

plus the usual .sig files.
Full announcement is at
  https://alioth-lists.debian.net/pipermail/pkg-libburnia-devel/2021-February/002915.html

Thanks for packaging libburnia.


Have a nice day 

Thomas

Should be good to go as of yesterday at noon!

comment:5 by Douglas R. Reno, 6 months ago

Summary: libburn libisoburn libisofs 1.5.4 (Waiting on the maintainer to release new versions)libburn libisoburn libisofs 1.5.4

comment:6 by Douglas R. Reno, 6 months ago

Here are the release notes for everything, straight from the release announcement:

Hi,

libburnia project is pleased to announce the release of version 1.5.4:

libburn,    a burn backend library for CD, DVD and BD.
cdrskin,    a burn backend binary with a command line interface
            compatible to cdrecord.
libisofs,   a library for creation and manipulation of ISO 9660
            filesystems.
libisoburn, a library which coordinates libburn and libisofs
            to perform multi-session on all random access readable
            and writable media and file objects.
xorriso,    an integrated ISO 9660 multi-session tool with
            additional emulation of mkisofs.

System requirements:
- Linux   : kernel 2.4 or newer, libc, libpthread
- FreeBSD : libc, libpthread, IDE and SATA drives need atapicam
- Solaris : libc, libpthread
- NetBSD  : libc, libpthread
- OpenBSD : libc, libpthread
- on other X/Open systems there will be no direct operation of
  CD/DVD/BD drives, but only POSIX i/o which may or may not
  be offered by the system for DVD-RAM, DVD+RW, or BD-RE.


Changes:

libburn offers new opportunities to influence drive speed.
libisofs got a bug fixed which under medium rare circumstances spoiled
zisofs production. libisofs switched to usage of libjte-2.0.0. Further it
can now write and read zisofs2 format, which enables compression of files
>= 4 GiB. When reading Joliet file trees, the names get stripped of their
version numbers by default. After loading metadata, libisofs can now tell
which directory tree was loaded and whether Rock Ridge is used.
libisoburn and xorriso make use of these new features.
xorriso can put out the data stream of -check_media to standard output. It
can restore files with many zero bytes as sparse files and it is able to
extract recognized boot images into data files on hard disk.
A new script xorriso-dd-target helps to put an ISO image onto an USB stick
without endangering valuable hard disk content.
Several rarely triggered bugs were fixed.

libburn and cdrskin novelties:

* Bug fix: Early SCSI commands from sg-linux.c were not logged
* New API call burn_drive_set_speed_exact()
* New API call burn_nominal_slowdown()

libisofs novelties:

* Bug fix: Large amounts of AAIP data or many long file names could cause with
           zisofs an unreadable filesystem after the warning "Calculated and
           written ECMA-119 tree end differ"
* Bug fix: Big-Endian MIPS Volume Header boot file size was rounded up to
           full 2048. Thanks René Rebe.
* Bug fix: El Torito production failed if no catalog path is given and the
           first boot image path contains no slash
* Bug fix: zisofs production was wrong on big-endian machines
* Bug fix: Apple Partition Map entries wrote uninitialized data
* Bug fix: Appended APM partitions without HFS+ production had start and size 1
* Switched to usage of libjte-2.0.0
* Implemented production and reading of zisofs2 for files larger than 4 GiB - 1
* New struct iso_zisofs_ctrl version 2
* New API call iso_stream_get_zisofs_par()
* New API call iso_stream_zisofs_discard_bpt()
* New API call iso_image_zisofs_discard_bpt()
* New flag bits 8 to 15 in API call iso_node_zf_by_magic()
* New API call iso_zisofs_ctrl_susp_z2()
* New API call iso_read_opts_set_joliet_map(), new default joliet_map=stripped
* New API calls iso_read_image_features_tree_loaded() and
  iso_read_image_features_rr_loaded()

libisoburn novelties:

* Switched to usage of libjte-2.0.0
* Enabled recognition of zisofs by magic without zlib support
* New libisoburn extension options isoburn_ropt_map_joliet_stripped and
  isoburn_ropt_map_joliet_unmapped
* New API call isoburn_ropt_get_tree_loaded()

----------------------------------------------------------------------------
Peculiarities of this release:

A 5 year old bug of libisofs about zisofs was reported when the release
tags in git already existed and GNU xorriso-1.5.4.tar.gz was already
uploaded. This halted the final steps of the release for a week.

The now released state is:

- libisofs-1.5.4 has the bug fixed. Because no upload had happened yet,
  the tarball still goes by the name libisofs-1.5.4.tar.gz .
  The old libisofs release tag was changed to "release-1.5.4.rc1".
  The current tag "release-1.5.4" marks the code state of the now released
  libisofs-1.5.4.tar.gz .

- GNU xorriso has been patched to xorriso-1.5.4.pl02.tar.gz which is now
  uploaded. (By a moment of inattention i failed to fix the bug in .pl01,
  which got uploaded before i noticed.)

----------------------------------------------------------------------------

comment:7 by Douglas R. Reno, 6 months ago

Resolution: fixed
Status: assignedclosed

Fixed at r24203

Note: See TracTickets for help on using tickets.