Opened 4 months ago

Closed 4 months ago

#14788 closed enhancement (fixed)

sqlite-autoconf-3350300 (3.35.3)

Reported by: Bruce Dubbs Owned by: Douglas R. Reno
Priority: normal Milestone: 10.2
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (5)

comment:1 by Xi Ruoyao, 4 months ago

Summary: sqlite-autoconf-3340200 (3.35.2)sqlite-autoconf-3350200 (3.35.2)

comment:2 by Douglas R. Reno, 4 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:3 by Douglas R. Reno, 4 months ago

Summary: sqlite-autoconf-3350200 (3.35.2)sqlite-autoconf-3350300 (3.35.3)

Now 3.35.3!

comment:4 by Douglas R. Reno, 4 months ago

Additional changes in version 3.35.2 (2021-03-17):

    Fix a problem in the appendvfs.c extension that was introduced into version 3.35.0.
    Ensure that date/time functions with no arguments (which generate responses that depend on the current time) are treated as non-deterministic functions. Ticket 2c6c8689fb5f3d2f
    Fix a problem in the sqldiff utility program having to do with unusual whitespace characters in a virtual table definition.
    Limit the new UNION ALL optimization described by item 8c in the 3.35.0 release so that it does not try to make too many new subqueries. See forum thread 140a67d3d2 for details. 

Additional changes in version 3.35.3:

    Enhance the OP_OpenDup opcode of the bytecode engine so that it works even if the cursor being duplicated itself came from OP_OpenDup. Fix for ticket bb8a9fd4a9b7fce5. This problem only came to light due to the recent MATERIALIZED hint enhancement.
    When materializing correlated common table expressions, do so separately for each use case, as that is required for correctness. This fixes a problem that was introduced by the MATERIALIZED hint enhancement.
    Fix a problem in the filename normalizer of the unix VFS.
    Fix the "box" output mode in the CLI so that it works with statements that returns one or more rows of zero columns (such as PRAGMA incremental_vacuum). Forum post afbbcb5b72.
    Improvements to error messages generated by faulty common table expressions. Forum post aa5a0431c99e.
    Fix some incorrect assert() statements.
    Fix to the SELECT statement syntax diagram so that the FROM clause syntax is shown correctly. Forum post 9ed02582fe.
    Fix the EBCDIC character classifier so that it understands newlines as whitespace. Forum post 58540ce22dcd.
    Improvements the xBestIndex method in the implementation of the (unsupported) wholenumber virtual table extension so that it does a better job of convincing the query planner to avoid trying to materialize a table with an infinite number of rows. Forum post b52a020ce4. 

sqlite-3.35.x seems to have a lot of regressions.

comment:5 by Douglas R. Reno, 4 months ago

Resolution: fixed
Status: assignedclosed

Fixed at r24405

Note: See TracTickets for help on using tickets.