Opened 4 months ago

Closed 3 months ago

#14878 closed enhancement (fixed)

pipewire-0.3.26

Reported by: Douglas R. Reno Owned by: Douglas R. Reno
Priority: normal Milestone: 10.2
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

Change History (4)

comment:1 by Douglas R. Reno, 4 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:2 by Xi Ruoyao, 3 months ago

Summary: pipewire-0.3.25pipewire-0.3.26

Now 0.3.26.

comment:3 by Douglas R. Reno, 3 months ago

0.3.25

PipeWire 0.3.25

This is a bugfix release that is API and ABI compatible
with previous 0.3.x releases.

- Highlights
  - Many stability improvements.
  - Plug fd leak in flatpak detection
  - add pw-loopback tool and support module-loopback
  - volume restore for virtual sinks/sources or other sink/sources
    without hardware volume.
  - Fix cracks and pops in audio capture.
  - Many bluetooth improvements and compatibility fixes.


- PipeWire improvements
  - Hex encode invalid SEC_LABEL properties to avoid generating
    invalid json.
  - Small fixes to how nodes are started to avoid crashes.
  - Make sure ports are only scheduled after being fully
    negotiated to avoid crashes.
  - Implement coverity into CI, fix some bugs detected by
    coverity.
  - Plug leak in flatpak detection.
  - Fix crash when removing globals in some cases.
  - Fix crash because the mixer info was not removed from a
    port in all cases.
  - Add PIPEWIRE_AUTOCONNECT environment variable to disable
    stream autoconnect. Also add a config option to disable
    autoconnect.
  - Improve wildcard in format helpers.
  - Add env variable to disable journald logging.

- Tools
  - Add a new pw-loopback tool to loop a capture device to a
    playback device.
  - Display localized strings correctly in pw-top
  - Add some more options to pw-dot

- Session-manager
  - When a new node is configured and some stream have this
    as the default target, move them to it.
  - Fix some crashes.
  - Implement volume restore on nodes without routes. This makes
    it possible to restore volume on purely software nodes like
    null-sinks.
  - Also try to suspend errored nodes so that they may leave the
    error state and be reused again.
  - Break endless link loops when something went wrong.

- Device support
  - Fix monitor volumes, they are now separate from the hardware
    volume.
  - Fix cracks and pops in alsa capture caused by mismatch between
    resampler and capture source.
  - Add start-delay config option to alsa sink.
  - Ensure the PipeWire midi ports start from a higher number so
    that the lower port numbers are available to apps as before.

- Bluetooth
  - source devices are now removed when idle
  - Support using pipewire as Audio Gateway.
  - LDAC encoding quality can be configured now
  - Implement codec switching for HFP
  - Implement codec switching with new device property.
  - Improved stability and compatibility
  - Autoconnect device profiles at startup
  - Add AAC bitrate mode configuration
  - Make it possible to use an A2DP source as an input device. You
    can then use your phone as an A2DP microphone, for example.
  - Remove battery reporting when RFCOMM connections is closed.

- PulseAudio server
  - Add some workarounds for Blueman
  - Set correct errno values, fixes a hang in load-module of a
    non-existing module
  - Try to not send inconsistent information to clients.
  - Fix some crashes.
  - Add support for the new send-message API, use this to
    switch bluetooth codecs.
  - Fix draining by making sure we are started.
  - Handle 0 sink and source as the default sink/source.
  - Implement module-loopback

- JACK
  - Fix some memory leaks when closing a client
  - Add self-connect config option to limit where clients
    can connect themselves.
  - Don't crash when apps call _port_get_buffer() on a
    port that is not their own but simply return NULL.
    This fixes a crash in Ardour6.
  - Improve client added/removed callbacks. Sometimes it would
    emit a client remove when there were still ports for the
    client.
  - make sure midi port names are stable across reboots.

0.3.26

PipeWire 0.3.26

This is a bugfix release that is API and ABI compatible
with previous 0.3.x releases.

- Highlights
  - I18n support, with translations merged from PulseAudio.
  - New pw-link tool.
  - Many Bluetooth improvements, support for hardware volumes.
  - Support for 64 channel devices.
  - Stability fixes and improvements.


- PipeWire improvements
  - The link factory can now also make links between nodes and
    ports by name so that it can be used in scripts.
  - Add module-protocol-simple that can stream raw audio on a
    socket.
  - Added i18n support. Merge PulseAudio translations for the ACP
    library so that we don't cause regressions.
  - Support more than 19 channels in the channel mixer.
    This makes all channels usable on 32 and 64 channel cards.
  - Detect if we're running in a VM and allow for tweaking some
    settings such as the max-quantum to make things work better in
    VMs.
  - Fix a potential crash when connecting a client and updating
    permissions.
  - Fix a potential crash when trying to link incompatible ports.
  - Lingering links in error will now be destroyed automatically.

- Tools
  - Added new pw-link tool to list and monitor ports and to
    list, monitor, create and destroy links between them.
  - pw-cli can now also list params by name.
  - pw-dump now outputs Spa:String:JSON types in metadata as properly
    parsed and formatted JSON so that tools can parse the
    metadata values using a JSON parser.

- Session-manager
  - Add logind support. The bluetooth monitor can only be started
    for one user at the time, so use logind detect active seats.
  - ALSA icon names were improved to match what PulseAudio does.
  - Improve the bluetooth icon name. Also use the device alias
    as the device description, like PulseAudio.

- Device support
  - When devices become inaccessible, they are now removed from
    the PipeWire graph.
  - Fix datatype selection for buffers in v4l2 and libcamera.

- Bluetooth
  - Various memory leaks and crashes are fixed.
  - Added support for AVRCP hardware volume.
  - Added support for HSP/HFP hardware volume.

- PulseAudio server
  - Fix module-loopback connections to monitor ports.
  - Implement module-native-protocol-tcp.
  - Handle nodes and streams with > 32 channels. The PulseAudio
    API only supports up to 32 channels so only make those 32
    first channels available with the PA API.
  - Implement module-simple-protocol-tcp.
  - Improve events emitted by the server.
  - Improvements to channels and channel_map properties on
    modules. one can imply the other and they should match when
    both given.
  - null-sink will now have their volume work correctly by
    default.

- JACK
  - JACK development files can now optionally be installed.

We'll have to see later how well this update performs on elogind, considering that it's now using the logind() interface for session management

comment:4 by Douglas R. Reno, 3 months ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.