#15356 closed enhancement (fixed)

pipewire-0.3.33

Reported by: Bruce Dubbs Owned by: Bruce Dubbs
Priority: normal Milestone: 11.0
Component: BOOK Version: git
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by Bruce Dubbs, 14 months ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Bruce Dubbs, 14 months ago

# PipeWire 0.3.33 (2021-08-05)

This is a bugfix release that is API and ABI compatible with previous 0.3.x releases.

## Highlights

  • Better support for virtual sinks/sources for Pro Audio profile.
  • Better DMA-BUF format modifier negotiation.
  • Support multiple sample rates in the graph. Not enabled by default yet.
  • Bluetooth can now automatically switch between headset and audio profile.
  • Documentation updates.
  • Many improvements and crasher fixes.

## PipeWire

  • Make AUX channels an official channel map, use this for the PRO audio profile so that we can name the channels. This make it possible to define virtual sources and sinks for Pro Audio devices in a more reliable way.
  • Fix scheduling of some virtual sinks/sources.
  • Fix potential corruption of ringbuffer because of multiple concurrent writers. This might be the cause for many reported crashes.
  • Don't place sockets in $HOME.
  • Improve DMA-BUF negotiation. Add a flag to avoid fixation of a property so that producers can negotiate more efficiently. This is used to negotiate DMA-BUF modifiers, which should make more efficient use of the GPU.
  • Add support for multipe sample rates. The graph can switch when IDLE to one of the supported rates. Add an option to lock the rate as well. This is not enabled by default yet because of driver bugs that need to be worked around first.
  • Add node.lock-quantum property that can be used to lock the quantum in place.
  • Improve latency reporting in the loopback module.
  • Make new client-node method to send the peer port id to the mixer. This can be used to know where the buffers entering the mixer are coming from.

## Tools

  • pw-top should now also correctly show bluetooth devices.

## media-session

  • Handle unset of the default node.
  • Added a module that can switch the bluetooth profile to headset profile when a stream wants to record from it.

## JACK

  • Only call the jack callbacks when the client is active. Some JACK applications don't expect callbacks before the client is active and crash (x42-dpl).
  • Emit client unregister event.
  • Add per-client match rules in the config file to set app specific configuration and tweaks.
  • Use peer_id to implement jack_port_get_buffer() from one of our peer ports to get the data before it enters the mixer. Makes the capture monitors work in Ardour6.8.

## Bluetooth

  • Add some broken kernel versions to the mSBC blocklist
  • Avoid looping and consuming CPU when we can't write to the BT socket.
  • Use libfreeaptx instead of libopenaptx.
  • Fix rounding errors in HW volume conversion.

## PulseAudio server

  • implement module-switch-on-connect to emulate pulseaudio behaviour of new devices. Some desktop environments expect this behaviour and break otherwise.
  • Fix stream cleanup, make sure the stream is stopped before destroying it. Might be cause for some of the reported crashes.
  • Update message API to use the JSON format.

## Other

  • Many documentation updates.
  • Many cleanups and small improvements.
  • Support the latest libcamera version.

comment:3 by Bruce Dubbs, 14 months ago

Resolution: fixed
Status: assignedclosed

Fixed at commit 79fe32decef10ac8de3a228f4ef17bf1664f0005

Package updates.
    Update to pipewire-0.3.33.
    Update to glib-networking-2.68.2.
    Update to SCons-4.2.0.
Note: See TracTickets for help on using tickets.