Opened 6 weeks ago

Closed 6 weeks ago

#15532 closed enhancement (fixed)

libatomic_ops-7.6.12

Reported by: Bruce Dubbs Owned by: Bruce Dubbs
Priority: normal Milestone: 11.1
Component: BOOK Version: git
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by Bruce Dubbs, 6 weeks ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Bruce Dubbs, 6 weeks ago

[7.6.12] 2021-09-13

  • Allow to generalize bool-CAS for sparc (gcc)
  • Declare argument of AO_load_next with const in atomic_ops_stack
  • Describe double_compare_and_swap operation in README_details
  • Document CAS operations better in README_details
  • Fix gcc/sunc x86 AO_compare_double_and_swap_double missing side effect
  • Fix library name in README_details
  • Fix link fail caused by missing GCC char/short atomic primitives on riscv64
  • Fix size of local variable passed to cas[x] (gcc/sparc)
  • Implement fetch-CAS for sparc (gcc)
  • Refactor gcc x86 memory constraints
  • Refine and reformat description of size prefix in README_details
  • Remove outdated notes in README_details
  • Replace x86 setz instruction by asm flag output operand (gcc)
  • Support MSYS host (configure)
  • Turn off compare_double_and_swap_double_full PIC hack for GCC 5+ (x86)
  • Update README_win32 to match Makefile.msft
  • Use GCC atomic intrinsics for s390x (clang 8.0+ and gcc 5.4+)
  • Use alignof instead of sizeof in atomic variable alignment assertions
  • Workaround assertion violation in AO_load/store on m68k

comment:3 by Bruce Dubbs, 6 weeks ago

Resolution: fixed
Status: assignedclosed

Fixed at commit b42891ad411e287ac59973dbc4e021fae6e83b08

Package Updates.
    Update to libatomic_ops-7.6.12.
    Update to sudo-1.9.8.
    Update to libass-0.15.2.
    Update to libexif-0.6.23.
    Update to ModemManager-1.18.0.
Note: See TracTickets for help on using tickets.