Opened 12 months ago

Closed 4 months ago

#15568 closed enhancement (fixed)

libsoup-3.0.6 (hold until all Web KitGTK users port to web kit2gtk-4.1)

Reported by: Bruce Dubbs Owned by: blfs-book
Priority: normal Milestone: 99-Waiting
Component: BOOK Version: git
Severity: normal Keywords:
Cc:

Description

New major version.

Change History (27)

comment:1 by Xi Ruoyao, 12 months ago

It's ABI and API incompatible with libsoup-2.x, and currently there is no BLFS package needing it.

Maybe we'd mark it "wait until something need it" and/or clone libsoup page?

comment:2 by Xi Ruoyao, 12 months ago

I think it's just problematic:

We should really wait for it to be settled down.

Last edited 12 months ago by Xi Ruoyao (previous) (diff)

in reply to:  2 comment:3 by Douglas R. Reno, 12 months ago

Replying to Xi Ruoyao:

I think it's just problematic:

We should really wait for it to be settled down.

I concur. Bruce created a GNOME-41 milestone for me this morning, so I'll move relevant tickets over there shortly. We'll do this one when I do the others, but as a separate page I think (assuming we can find a way to co-install it, will have to investigate that later).

comment:4 by Douglas R. Reno, 12 months ago

Milestone: 11.1Gnome41

Move to GNOME 41.

comment:5 by Xi Ruoyao, 12 months ago

Status update:

  • tracker-3.2.0 can be built with libsoup-3.0 (default is both libsoup-2.x and libsoup-3.0), but valac need to be patched.
  • webkitgtk-2.34.0 can be built with libsoup-3.0 (and it's the default), but the SONAME will bump to libwebkit2gtk-4.1.so.xx. I'm not sure if it's supported by GNOME 41.

comment:6 by Xi Ruoyao, 12 months ago

I think it should be retargeted to GNOME 42.

Some parts of GNOME 41 will support libsoup 3, but the others not. And, it seems all of the GNOME parts will continue to support libsoup 2 (at least for GNOME 41).

If we build libsoup 3 along with libsoup 2, the problem is webkitgtk's ABI will change. Likewisely, some GNOME 41 parts (epiphany) supports the new ABI, while the others (gnome-online-accounts) not. And webkitgtk is a giant package, we don't want to build it twice...

comment:7 by Xi Ruoyao, 12 months ago

Or, we can install libsoup 3 alongwith libsoup 2, but use -DUSE_SOUP2 for WebKitGTK (and maybe, the equivelent for some other packages).

Last edited 12 months ago by Xi Ruoyao (previous) (diff)

comment:8 by Xi Ruoyao, 12 months ago

GNOME people seems waiting for libwebkit2gtk-5.0.so.xx which uses libsoup-3 and gtk-4, and just skip libwebkit2gtk-4.1.so.xx. So we'd do the same IMO.

comment:9 by Xi Ruoyao, 12 months ago

So basically we have two options:

  1. Retarget libsoup-3 to GNOME 42 (or "x-future", or BLFS 11.2), and add a note in libsoup-2 saying "don't install libsoup-3 unless you know what you are doing".
  2. Install libsoup-3 along with libsoup-2 (clone the page), but use -DUSE_SOUP2 for WebKitGTK.
Last edited 12 months ago by Xi Ruoyao (previous) (diff)

comment:10 by Bruce Dubbs, 12 months ago

Milestone: Gnome41gnome41

Milestone renamed

comment:11 by Bruce Dubbs, 12 months ago

Milestone: gnome4141gnome

Milestone renamed

comment:12 by Bruce Dubbs, 12 months ago

Milestone: 41gnomegnome-41

Milestone renamed

comment:13 by Xi Ruoyao, 12 months ago

Milestone: gnome-41hold
Summary: libsoup-3.0.0libsoup-3.0.0 (hold until GNOME 42)

Move to hold.

Meanwhile I'll add a note into the book.

comment:14 by Xi Ruoyao, 12 months ago

The main users of webkitgtk are evolution{,-data-server}, g-o-a, epiphany, and yelp. Now yelp and epiphany supports webkit2gtk-4.1 (i. e. webkitgtk built with soup 3), so if g-o-a and evolution-* supports it as well we can move soup3 back to GNOME 41.

However evolution and e-d-s 3.42 are already released w/o soup3 support. Not sure if they'll make a point release to support soup3.

Last edited 12 months ago by Xi Ruoyao (previous) (diff)

comment:15 by Xi Ruoyao, 12 months ago

Summary: libsoup-3.0.0 (hold until GNOME 42)libsoup-3.0.0 (hold until all WebKitGTK users port to webkit2gtk-4.1)

comment:16 by Douglas R. Reno, 12 months ago

Summary: libsoup-3.0.0 (hold until all WebKitGTK users port to webkit2gtk-4.1)libsoup-3.0.1 (hold until all WebKitGTK users port to webkit2gtk-4.1)

Now to 3.0.1

comment:17 by Xi Ruoyao, 11 months ago

The tracking issue of libsoup3 porting is: https://gitlab.gnome.org/GNOME/libsoup/-/issues/218

comment:18 by Douglas R. Reno, 11 months ago

Summary: libsoup-3.0.1 (hold until all WebKitGTK users port to webkit2gtk-4.1)libsoup-3.0.2 (hold until all WebKitGTK users port to webkit2gtk-4.1)

Now 3.0.2

comment:19 by Douglas R. Reno, 10 months ago

Summary: libsoup-3.0.2 (hold until all WebKitGTK users port to webkit2gtk-4.1)libsoup-3.0.3 (hold until all WebKitGTK users port to webkit2gtk-4.1)

Now 3.0.3

comment:20 by Douglas R. Reno, 9 months ago

Summary: libsoup-3.0.3 (hold until all WebKitGTK users port to webkit2gtk-4.1)libsoup-3.0.4 (hold until all WebKitGTK users port to webkit2gtk-4.1)

Now 3.0.4

comment:21 by Bruce Dubbs, 8 months ago

Milestone: hold99-Waiting

comment:22 by Xi Ruoyao, 6 months ago

Need to wait until at least GNOME 43. In GNOME-42 evolution and gnome-online-accounts will block us.

comment:23 by Douglas R. Reno, 6 months ago

Summary: libsoup-3.0.4 (hold until all WebKitGTK users port to webkit2gtk-4.1)libsoup-3.0.5 (hold until all WebKitGTK users port to webkit2gtk-4.1)

Now 3.0.5

comment:24 by Douglas R. Reno, 6 months ago

Summary: libsoup-3.0.5 (hold until all WebKitGTK users port to webkit2gtk-4.1)libsoup-3.0.6 (hold until all WebKitGTK users port to webkit2gtk-4.1)

Now 3.0.6

comment:25 by Bruce Dubbs, 4 months ago

Summary: libsoup-3.0.6 (hold until all WebKitGTK users port to webkit2gtk-4.1)libsoup-3.0.6 (hold until all Web KitGTK users port to web kit2gtk-4.1)

Don't mention 'webkit' in summary. Interferes with webkit currency.

comment:26 by Bruce Dubbs, 4 months ago

Changes in libsoup from 3.0.5 to 3.0.6:

  • Misc HTTP/2 fixes
  • Add PUT/POST support to examples/get
  • Add --user-agent option to examples/get
  • Misc meson improvements
  • Fix build with Visual Studio

comment:27 by Bruce Dubbs, 4 months ago

Resolution: fixed
Status: newclosed

Marking fixed at commit 941e3b09ceac54759c1d978e212499efe5583479.

Reopen is we need to remove libsoup3 from the book.

Note: See TracTickets for help on using tickets.