Opened 4 weeks ago

Closed 3 weeks ago

#15581 closed enhancement (fixed)

cmake-3.21.3

Reported by: Bruce Dubbs Owned by: thomas
Priority: normal Milestone: 11.1
Component: BOOK Version: git
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (2)

comment:1 by thomas, 3 weeks ago

Owner: changed from blfs-book to thomas
Status: newassigned

https://cmake.org/cmake/help/latest/release/3.21.html#id3

The Visual Studio 17 2022 generator is now based on "Visual Studio 2022 Preview 4". Previously it was based on "Preview 3.1".

The AMD ROCm Platform hipcc compiler was identifed by CMake 3.21.0 through 3.21.2 as a distinct compiler with id ROCMClang. This has been removed because it caused regressions. Instead:

hipcc may no longer be used as a HIP compiler because it interferes with flags CMake needs to pass to Clang. Use Clang directly.

hipcc may once again be used as a CXX compiler, and is treated as whatever compiler it selects underneath, as CMake 3.20 and below did.

comment:2 by thomas, 3 weeks ago

Resolution: fixed
Status: assignedclosed

Fixed in [6f07ff1]

Note: See TracTickets for help on using tickets.