Opened 2 months ago

Closed 5 weeks ago

#15612 closed enhancement (fixed)

cifs-utils-6.14

Reported by: Bruce Dubbs Owned by: Douglas R. Reno
Priority: normal Milestone: 11.1
Component: BOOK Version: git
Severity: normal Keywords:
Cc:

Description

New minor version.

Change History (3)

comment:1 by Douglas R. Reno, 2 months ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

Grab this set of tickets.

comment:2 by Douglas R. Reno, 5 weeks ago

New version 6.14 of cifs-utils has been released today.

Highlighted changes:

- smbinfo is enhanced with capability to display alternate data streams
- setcifsacl is improved to optionally reorder ACEs in preferred order
- cifs.upcall regression in kerberos mount is fixed

webpage: https://wiki.samba.org/index.php/LinuxCIFS_utils
tarball: https://download.samba.org/pub/linux-cifs/cifs-utils/
git: git://git.samba.org/cifs-utils.git
gitweb: http://git.samba.org/?p=cifs-utils.git;a=summary

Detailed list of changes since 6.13 was released:

8c06dce cifs-utils: bump version to 6.14
e2e216c setcifsacl: fix formatting
1a70243 smbinfo: add support for new key dump ioctl
9ad46fc mount.cifs: fix crash when mount point does not exist
7f9711d cifs.upcall: fix regression in kerberos mount
02cd3aa smbinfo: Add command for displaying alternate data streams
4d5daf5 Reorder ACEs in preferred order during setcifsacl

Summary:

Aurelien Aptel (2):
  cifs.upcall: fix regression in kerberos mount
  smbinfo: add support for new key dump ioctl

Juan Pablo González (1):
  smbinfo: Add command for displaying alternate data streams

Paulo Alcantara (1):
  mount.cifs: fix crash when mount point does not exist

Pavel Shilovsky (2):
  setcifsacl: fix formatting
  cifs-utils: bump version to 6.14

Rohith Surabattula (1):
  Reorder ACEs in preferred order during setcifsacl

 cifs.upcall.c     | 214 +++++++++++++++++++++++++++++++++++-------------------
 configure.ac      |   2 +-
 mount.cifs.c      |  13 ++--
 setcifsacl.c      | 129 +++++++++++++++++++++++++++++++-
 setcifsacl.rst.in |  20 ++++-
 smbinfo           | 120 ++++++++++++++++++++++++++----
 smbinfo.rst       |   2 +
 7 files changed, 399 insertions(+), 101 deletions(-)

comment:3 by Douglas R. Reno, 5 weeks ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.