#15709 closed enhancement (fixed)

xorg-server-21.1.1

Reported by: Bruce Dubbs Owned by: pierre
Priority: normal Milestone: 11.1
Component: BOOK Version: git
Severity: normal Keywords:
Cc:

Description (last modified by ken@…)

New version. Was 21.1.0, now 21.1.1

Change History (9)

comment:1 by Xi Ruoyao, 13 months ago

It needs a new library, libxcvt: https://www.x.org/archive//individual/lib/libxcvt-0.1.1.tar.xz

libxcvt is a simple MNNI package.

comment:2 by Douglas R. Reno, 13 months ago

XWayland has also been separated out and will need to be added as a new package.

in reply to:  2 ; comment:3 by Xi Ruoyao, 13 months ago

Replying to Douglas R. Reno:

XWayland has also been separated out and will need to be added as a new package.

Both Xorg and Xwayland installs xvfb. We should disable xvfb in one of them.

in reply to:  3 comment:4 by Douglas R. Reno, 13 months ago

Replying to Xi Ruoyao:

Replying to Douglas R. Reno:

XWayland has also been separated out and will need to be added as a new package.

Both Xorg and Xwayland installs xvfb. We should disable xvfb in one of them.

I'm in no position to do research at the moment, but I'd think probably Xwayland should have it disabled.

comment:5 by ken@…, 13 months ago

Description: modified (diff)
Summary: xorg-server-21.1.0xorg-server-21.1.1

For 21.1.1:

This release fixes two relatively important issues that slipped into 21.1.0.

Jon Turney (1):

s//@/ in inputtestdrv manpage

Matthieu Herrb (1):

Make xf86CompatOutput() return NULL when there are no privates

Povilas Kanapickas (2):

Makefile.am: Add missing meson build files to release tarball xserver 21.1.1

git tag: xorg-server-21.1.1

https://xorg.freedesktop.org/archive/individual/xserver/xorg-server-21.1.1.tar.gz SHA256: bd809c59e3f887eb75c8ba9e0160a234a8cee87145771158907ad5ae2ec80b1a xorg-server-21.1.1.tar.gz SHA512: 817720333128cd235dc508eddaa70e1698151e32a48097146c759af7becbf55ccfc0a56891db124a1b23a7a89e98e4daea34 fa440290099cbb92c3b465113d85 xorg-server-21.1.1.tar.gz PGP: https://xorg.freedesktop.org/archive/individual/xserver/xorg-server-21.1.1.tar.gz.sig

https://xorg.freedesktop.org/archive/individual/xserver/xorg-server-21.1.1.tar.xz SHA256: 782e7fef2ca0c7cbe60a937b8bf42dac69c904fb841950fd0363e1c2346ea755 xorg-server-21.1.1.tar.xz SHA512: 8608ed9c1537c95e8a3adea5e3e372a3c5eb841f8e27c84283093f22fb1909e16a800006510da684b13f8f237f33b8a4be3e 2537f5f9ab9af4c5ad12770eef0d xorg-server-21.1.1.tar.xz PGP: https://xorg.freedesktop.org/archive/individual/xserver/xorg-server-21.1.1.tar.xz.sig

comment:6 by pierre, 13 months ago

Owner: changed from blfs-book to pierre
Status: newassigned

comment:7 by pierre, 13 months ago

From Marty Jack, on blfs-dev:

When you get to xorg-server 21.1.1 (21.1.0 had a new release engineer and a bunch of missing files) there is a patch you should strongly consider.

https://github.com/archlinux/svntogit-packages/blob/packages/xorg-server/trunk/0001_revert_dpi_calculation.patch

Without this, some applications render huge.  In my testing it was limited to xterm and Qt 5 (but not 6) applications.

comment:8 by pierre, 13 months ago

[ANNOUNCE] xorg-server 21.1.0
This is the final release of X server 21.1. There has been just one fix since
the second RC and at this time there are no known regressions since the 1.20
release series.

I expect that increased usage after the final release may still uncover
something interesting, so there is a potential for subsequent 21.1.1 patch
being released in the coming weeks rather than after the usual interval of
several months.

Notable changes since 1.20 include:

  - The meson support is now fully mature. While autotools support will still be
  kept for this release series, it will be dropped afterwards.

  - Glamor support for Xvfb.

  - Variable refresh rate support in the modesetting driver.

  - XInput 2.4 support which adds touchpad gestures.
  
  - DMX DDX has been removed.
  
  - X server now correctly reports display DPI in more cases. This may affect
  rendering of client applications that have their own workarounds for hi-DPI
  screens.

  - A large number of small features and various bug fixes.

Note that since 21.1 series XWayland is released separately and thus this
release does not include it.

comment:9 by pierre, 13 months ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.