Opened 16 years ago

Closed 15 years ago

#1710 closed task (fixed)

GNOME-2.14.3

Reported by: Randy McMurchy Owned by: Randy McMurchy
Priority: normal Milestone: 6.2.0
Component: BOOK Version: SVN
Severity: normal Keywords: GNOME
Cc: Nico R.

Description (last modified by Randy McMurchy)

Status update:

1) All the core packages are completely updated to 2.14.3. 2) All the additional packages have had the versions

updated to be consistent with GNOME-2.14.3

3) The md5sums and build data must still be entered

for the additional packages that had minor version updates.

Attachments (3)

pam_console.diff (4.0 KB ) - added by dnicholson@… 15 years ago.
First cut for Linux-PAM patch
halusers.diff (4.7 KB ) - added by dnicholson@… 15 years ago.
Using hal without pam_console
gvm.diff (1.0 KB ) - added by dnicholson@… 15 years ago.
Explaining --disable-multiuser in g-v-m

Download all attachments as: .zip

Change History (35)

comment:1 by Randy McMurchy, 16 years ago

Status: newassigned

comment:2 by andy@…, 16 years ago

Cc: Nico R. added

comment:3 by andy@…, 16 years ago

* Bug 1724 has been marked as a duplicate of this bug. *

comment:4 by andy@…, 16 years ago

* Bug 1722 has been marked as a duplicate of this bug. *

comment:5 by Randy McMurchy, 16 years ago

Milestone: future6.2

GNOME core has been updated to 2.12.2. Some add-on packages have been checked out, the remainder will be addresses as time permits. I should be done inside a week.

comment:6 by Randy McMurchy, 16 years ago

Keywords: GNOME added
Summary: GNOME-2.12.2GNOME-2.14.0
Type: defecttask

Updating this bug to reflect the 2.14.0 version which will be released on 3/15. I'm submitting the last GNOME clean-up commits and have already started working with the 2.13.x branch.

comment:7 by Randy McMurchy, 16 years ago

One thing I'm going to do (if there are no objections) in this round of GNOME updates is change all the backticks (`) used in the --prefix commands to the more modern (and more functional in some cases) $(some_command) syntax.

comment:8 by dnicholson@…, 16 years ago

Randy, will you be adding gnome-screensaver and gnome-power-manager for 2.14?

comment:9 by Randy McMurchy, 16 years ago

GNOME Screensaver is highly likely as it is now listed as a core desktop package (http://ftp.gnome.org/pub/gnome/desktop/2.13/2.13.91/sources/).

GNOME Power Manager is a let-folks-decide-and-if-we-think-it-should-we-will kind of thing. Is it something mostly used for laptops?

BTW, most of the (what I call) core desktop packages are now in BLFS. There are some that are not, and I look at them each time to see if there is some compelling reason to add it to the book. Things like dasher, evolution-{exchange,webcal}, gnome-system-tools (only because I think it would confuse everyone what Distro to choose so that GNOME uses the right tool) and vino just don't strike me as useful enough to be in the book.

Of course, anyone provided input saying that these packages should be in the book will be very much considered. I don't like being the sole judge and jury. If someone thinks a particular package should be in the book, we will always consider it, then make a decision based on community input and the other criteria used to decide if a new package should be in the book.

comment:10 by julio28@…, 15 years ago

I, for me, think GNOME Power Manager would be a nice thing to include as I'm using a laptop, but I'm sure many users also use a laptop instead of a traditional desktop computer, so it would be good to give it a try (in my humble opinion)

anyway... it's supposed for the battery to respond or generate ACPI events, and maybe we should first add the corresponding dependency to HAL (acpid) for HAL to be able to manage events for GNOME Power Manager?

as a side note, I wrote a mail to the blfs-dev maillist some days ago about a correction in acpid, if this package is going to be considered (given the case GNOME Power Manager is going to be included in BLFS) maybe anyone should take a look into that mail...

Julio

comment:11 by dnicholson@…, 15 years ago

acpid is not a dependency of HAL. In fact, HAL and D-BUS completely deprecate the need for having a daemon listening for ACPI events. What is still needed are scripts for acting on the ACPI events. Right now, all the distros do their own thing.

However, there is a new project started by the maintainers of HAL and gnome-power-manager based on RedHat's power management scripts. It's still extremely fresh, but you could probably get it to work with HAL. Here's the CVS for the new project pm-utils:

http://webcvs.freedesktop.org/pm-utils/

A simpler implementation which needs a small patch to HAL is used by Paldo. See the acpid page (which installs nothing from the package now) and the HAL page.

http://www.paldo.org/index.php?section=packages&page=main&query=acpid
http://www.paldo.org/index.php?section=packages&page=main&releaseid=30736

comment:12 by particlehunter, 15 years ago

Randy, did you received my e-mail about the issues with ORBit2?

comment:13 by Randy McMurchy, 15 years ago

I received you email and just replied to it, Julio. And as mentioned in my reply, ORBit-2.14.0 compiles and tests perfectly for me.

comment:14 by Randy McMurchy, 15 years ago

Summary: GNOME-2.14.0GNOME-2.14.2

Targeting GNOME-2.14.2 now. It is due out on May 31st. I hope to have the book completly updated by June 7.

comment:15 by Randy McMurchy, 15 years ago

Well I sure misjudged that June 7th date. :-)

All GNOME2 packages have been updated. Here are outstanding issues:

1) gnome-mount needs some updating (pamconsole and other things

that I can't remember now)

2) Possibly GVM page needs updates as well (holding hands with #1) 3) Linux-PAM page updated with some info about pamconsole

New Packages 4) GNOME Screensaver will be added 5) Deskbar Applet may be added 6) Fast User Switch Applet may be added 7) GNOME Netstatus may be added 8) GNOME NetTool may be added

9) Anything else anyone can think of to make GNOME better

Dan, care to take a stab at the Gnome-mount/GVM/Linux-PAM stuff? Or at least some of it?

comment:16 by dnicholson@…, 15 years ago

Certainly. I've got a few hours tonight, so I'll try to work on that a bit. I'll probably post a book diff here before I commit anything.

I'd also like to see gnome-power-manager, but it might add difficulties like g-v-m and friends because it's pushing the envelope with HAL. Gnome-screensaver is working great for me. I think it's a big improvement over xscreensaver. (OT: Plus f-spot installs a gnome-screensaver plugin where you can do a slide show of selected photos that works as well as any I've ever seen.)

comment:17 by dnicholson@…, 15 years ago

Here's the first of a series of diffs that add optional pam_console. This is the first cut of the Linux-PAM changes. Later I'll post diffs for hal, gnome-volume-manager, shadow and gdm to make use of the optional pam_console.

by dnicholson@…, 15 years ago

Attachment: pam_console.diff added

First cut for Linux-PAM patch

comment:18 by Randy McMurchy, 15 years ago

Description: modified (diff)

comment:19 by Randy McMurchy, 15 years ago

Description: modified (diff)

(submitted again, this time in the correct place)

With all due respect to the very fine work Dan has done so far, I did not realize that a *different* version of Linux-PAM was necessary. This puts me 100% against the idea now. The reason being is I don't believe we can support it properly. Additionally, it means we need to update whenever RedHat releases an updated rev or adds a patch. To me, it simply isn't worth it.

I'm now for just leaving things the way they are and moving on without even a mention of pam_console in the book, other than perhaps a note saying to check out the Wiki for the (many) changes required if you want to use pam_console.

comment:20 by dnicholson@…, 15 years ago

OK. Well, hal and g-v-m still need info for configuration without pam_console. This is gonna have to wait until later. I'm out of time.

comment:21 by Randy McMurchy, 15 years ago

Please keep in mind, Dan, that I am just one out of the entire community. It may be that I'm the only one that thinks this cannot be properly supported. I wouldn't just completely drop it. Perhaps a discussion on -dev is appropriate.

comment:22 by dnicholson@…, 15 years ago

I put the pam_console info in the Wiki.

http://wiki.linuxfromscratch.org/blfs/wiki/linux-pam

It's essentially the same as the diff I submitted, but I found where the mythical tarball is located. This will work as a stopgap and allow patches for hal and g-v-m to be made that reference pam_console.

Feel free to comment on the wiki, or just make changes there.

by dnicholson@…, 15 years ago

Attachment: halusers.diff added

Using hal without pam_console

comment:23 by dnicholson@…, 15 years ago

Added a diff to the HAL page for configuring without pam_console.

comment:24 by dnicholson@…, 15 years ago

Adding a diff for g-v-m explaining the use of --disable-multiuser.

by dnicholson@…, 15 years ago

Attachment: gvm.diff added

Explaining --disable-multiuser in g-v-m

comment:25 by dnicholson@…, 15 years ago

I haven't thought a lot about the gnome-mount info. It's actually pretty good right now. I think the main benefit, though, is that gnome-mount gives you one generic way to invoke HAL mounting methods over D-BUS. So, gnome-vfs and gnome-volume-manager don't have to worry about how to mount things anymore. They just run gnome-mount with the device that's requested. Everything else including policy, mountpoint and mount options are taken care of.

The code in g-v-m for mounting right now basically boils down to

if (have_gnome_mount)
    ...run gnome-mount command with device udi...
else
    ...huge amount of redundant code figuring out mount options, talking to HAL
    over D-BUS, etc...

Hopefully in the future, there will be a way to store mount options in GConf. I think this is kind of in limbo right now.

comment:26 by Randy McMurchy, 15 years ago

Summary: GNOME-2.14.2GNOME-2.14.3

May as well sneak the 2.14.3 update into BLFS before 6.2 is released. This will be a very minor update requiring very little testing. This release is scheduled to be available on August 2nd, 2006.

comment:27 by Randy McMurchy, 15 years ago

Since there is already a Trac ticket for a GTK+-2 update (2-10.x) I'll annotate here that the book should be updated to GTK+-2.8.20

comment:28 by dnicholson@…, 15 years ago

No one has commented on the diffs I attached for describing hal/g-v-m use without pam_console. I will submit them soon if no one objects. The info for using pam_console is on the Wiki.

comment:29 by dnicholson@…, 15 years ago

See r6282. I don't know what the status is for the rest of the bug, but the hal/gnome-volume-manager/gnome-mount stuff should all be done.

comment:30 by Randy McMurchy, 15 years ago

Description: modified (diff)

comment:31 by Randy McMurchy, 15 years ago

All the Add-on Utility packages have had the md5sum and build data updated. The only remaining work to do is to update md5sums and build data for three Accessibility packages: GNOME Speech, GNOME Magnifier and Gnopernicus.

comment:32 by Randy McMurchy, 15 years ago

Resolution: fixed
Status: assignedclosed

Updated the accessibility packages to the 2.14.3 release. This completes the GNOME update and closing the ticket.

Note: See TracTickets for help on using tickets.