Opened 16 years ago

Closed 16 years ago

#1776 closed defect (invalid)

Explanation does not match configure options

Reported by: cmaier@… Owned by: blfs-book@…
Priority: lowest Milestone: 6.2.0
Component: BOOK Version: SVN
Severity: trivial Keywords:
Cc:

Description (last modified by Randy McMurchy)

Add configure option

--with-tk=/usr/lib

Add explanation

--with-tcl=/usr/lib: Use this option to link in the Tcl

Change History (4)

comment:1 by Randy McMurchy, 16 years ago

Resolution: invalid
Status: newclosed

This is unnecessary. This is what ./configure --help is for. We don't make it a policy to include every possible switch.

comment:2 by cmaier@…, 16 years ago

Resolution: invalid
Status: closedreopened

THe point of this bug is that the configure options shows one thing and the explanation describes another. The option shown has no description and the one described is not shown. Read the page before responding again, please. This is a typo, not my opinion.

comment:3 by Randy McMurchy, 16 years ago

Just going to leave the bug open for a while, and perhaps try and close it in a week or two. Though the book is correct, and the bug is invalid, there's not a whole lot we can do.

Perhaps some extra information, though unnecessary, could be added just so this type of thing doesn't happen again.

The issue is that some options are used on the configure line but are not explain in the "command explanations" section (they don't need to be explained as they are self-explanatory). Then, as a courtesy to the readers, an *additional* configure switch is shown in the command explanation section. This method is used throughout the book.

Perhaps the best thing after all might be to simply remove the explanation about tk and have nothing there.

comment:4 by Randy McMurchy, 16 years ago

Description: modified (diff)
Milestone: future6.2
Priority: highlowest
Resolution: invalid
Severity: normaltrivial
Status: reopenedclosed

Closing as invalid

Note: See TracTickets for help on using tickets.