Opened 16 years ago

Closed 14 years ago

#1869 closed task (fixed)

Guile-1.8.2

Reported by: Randy McMurchy Owned by: Randy McMurchy
Priority: normal Milestone: 6.3
Component: BOOK Version: SVN
Severity: normal Keywords: Guile
Cc:

Description

Version increment to 1.8.0

http://www.gnu.org/software/guile/

This package must be checked against SLIB, G-Wrap and GNUCash before updating.

Change History (9)

comment:1 by Randy McMurchy, 16 years ago

Noted in the new version

1) Installation commands don't change. Even the docs build the same. 2) GCC-4 patch not required 3) Installed libs are different 4) GMP is a required dependency 5) Emacs is an optional dependency

comment:2 by Randy McMurchy, 16 years ago

Owner: changed from blfs-book@… to Randy McMurchy

comment:3 by Randy McMurchy, 16 years ago

Status: newassigned

comment:4 by Randy McMurchy, 16 years ago

Resolution: fixed
Status: assignedclosed

Updated BLFS to Guile-1.8.0. Though this is a *major* realease of Guile, there are very few BLFS packages that use/link/rely on it and at should be a quiet update. SLIB, G-Wrap and GnuCash all seem to play nicely (did have to update to a -dev version of G-Wrap)

comment:5 by Randy McMurchy, 15 years ago

Milestone: 6.2future
Resolution: fixed
Status: closedreopened

Reopening so this will be updated after BLFS-6.2 has been released

comment:6 by Randy McMurchy, 15 years ago

Owner: changed from Randy McMurchy to blfs-book@…
Status: reopenednew

comment:7 by Randy McMurchy, 14 years ago

Milestone: future6.3

comment:8 by Randy McMurchy, 14 years ago

Owner: changed from blfs-book@… to Randy McMurchy
Status: newassigned

comment:9 by Randy McMurchy, 14 years ago

Resolution: fixed
Status: assignedclosed
Summary: Guile-1.8.0Guile-1.8.2

Updated BLFS to Guile-1.8.2

New SLIB works okay with this Guile version and G-Wrap is no longer needed by GnuCash, so there is no concern about G-Wrap compatibility.

Note: See TracTickets for help on using tickets.