Opened 3 years ago
Closed 3 years ago
#19386 closed enhancement (fixed)
nghttp2-1.60.0
| Reported by: | Bruce Dubbs | Owned by: | Bruce Dubbs |
|---|---|---|---|
| Priority: | normal | Milestone: | 12.2 |
| Component: | BOOK | Version: | git |
| Severity: | medium | Keywords: | |
| Cc: |
Description
New minor version.
Change History (3)
comment:2 by , 3 years ago
| Owner: | changed from to |
|---|---|
| Status: | new → assigned |
comment:3 by , 3 years ago
| Resolution: | → fixed |
|---|---|
| Status: | assigned → closed |
Fixed at commits
84398f0779 Update to pixman-0.43.4. a13351b39c Update to mdadm-4.3. 30360eb7f9 Update to nghttp2-1.60.0.
Note:
See TracTickets
for help on using tickets.

Note: The wiki markup before made the changes basically unreadable. We don't really care, for our purposes, who made the change to the package or what the url of the pull request was.
What's Changed
makerelease.sh: Speed up git submodule Speed up git clone build(deps): bump actions/cache from 3 to 4 Fixing the build and install trees build(deps): bump microsoft/setup-msbuild from 1 to 2 nghttpx: Set ocsp response to SSL in case of boringssl Run with python3 src: Certificate Compression with boringssl Fix missing newline Switch to aws lc Libbrotli fixup Deprecate RFC 7540 priorities (aka stream dependencies) Let dependabot manage go modules build(deps): bump golang.org/x/net from 0.20.0 to 0.21.0 integration-tests: Omit unused parameters Munit Introduce nghttp2_ssize API Move deprecated warning upfront b Describe RFC 7540 priorities deprecation plan b Apps migrate nghttp2 ssize src: Remove unused functions Reconsider ssize t usage in src Use GitHub private vulnerability reporting Move security policy to GitHub standard location Bump mruby to 3.3.0 Bump llhttp to 48588093ca4219b5f689acfc9ebea9e4c8c37663 h2load: Add --sni option Bump ngtcp2 dependencies mruby: Adopt deprecation of mrbc_ prefix neverbleed: Define _GNU_SOURCE for pthread_setaffinity_np bpf: Pre-expand aes key mruby: Exclude mrdb gem which causes nghttpx to crash nghttpx: Reuse EVP_CIPHER_CTX for QUIC connection ID encryption Run apt-get update before install src: Deal with the case that send_quantum < max_udp_payload_size nghttpx: Remove SHRPX_QUIC_MAX_UDP_PAYLOAD_SIZE Fix build when AI_NUMERICSERV is undefinedIMPORTANT
The APIs that uses
ssize_t, including structs and callback functions, have been deprecated. New APIs that usenghttp2_ssizeare introduced as a replacement. See https://github.com/nghttp2/nghttp2/pull/2066 for details. RFC 7540 priorities (aka stream dependencies) APIs have been deprecated. They work just like before, but in the future release after the end of 2024, the functionality is removed, and the deprecated APIs start behaving differently. See the API documentation for details. RFC 7540 priorities have been deprecated by RFC 9113. Consider migrating RFC 9218 extensible prioritization scheme.