Opened 15 years ago

Closed 15 years ago

#1979 closed task (fixed)

CUPS-1.2.7

Reported by: Randy McMurchy Owned by: Randy McMurchy
Priority: normal Milestone: 6.2.0
Component: BOOK Version: SVN
Severity: normal Keywords: CUPS
Cc:

Description

Version increment to 1.2.0.

http://www.cups.org/

This is a fairly major release. I'm going to install it and test with Samba, Ghostscript, Gimp-Print and other packages. If it turns out nothing breaks, perhaps the book can be updated before the 6.2 release.

Change History (9)

comment:1 by Randy McMurchy, 15 years ago

Status: newassigned

comment:2 by Randy McMurchy, 15 years ago

So far, I am very pleased with this package. There are some new features, especially in the web configuration interface. The HP LaserJet driver that ships with it is actually performing better than the Gimp-Print driver I've used in the past.

So far, everything that has tried to link to the libraries, does so and works as best as I can tell. This package is very likely to go into the 6.2 release.

Additional feedback would be appreciated.

comment:3 by Randy McMurchy, 15 years ago

Ticket 1940 will have to be hit at the same time this one is taken care of.

comment:4 by martyman99999, 15 years ago

I saw a mention of the KDE change for this in the preview 3.5.3 release notes, and 3.5.3 is expected out imminently, so that will be good timing for a quick retirement of the patch.

comment:5 by martyman99999@…, 15 years ago

And, 1.2.1 has showed up this evening, so we get a large raft of bugfixes as well.

comment:6 by Randy McMurchy, 15 years ago

Milestone: future6.2
Summary: CUPS-1.2.0CUPS-1.2.2

Version increment to 1.2.2. This is another package that I've done extensive testing with, and cannot see why it shouldn't be updated for the BLFS-6.2 release.

comment:7 by david.3r@…, 15 years ago

Another reason for upgrading to 1.2.2:

  • Version 1.1.23 fails to compile with the latest version of libpng, because it uses an obsolete libpng function.

Here's a patch that fixes this bug: http://bugs.gentoo.org/attachment.cgi?id=90787

comment:8 by dnicholson@…, 15 years ago

As we're getting a lot issues with cups-1.1.23 on blfs-support, it would be really great if this package could be updated soon. I've told everyone to try out cups-1.2.x, and the feedback has all been positive. Any chance we can bump up the priority on this guy?

http://linuxfromscratch.org/pipermail/blfs-support/2006-October/061092.html
http://linuxfromscratch.org/pipermail/blfs-support/2006-October/061117.html
http://linuxfromscratch.org/pipermail/blfs-support/2006-August/060806.html
http://linuxfromscratch.org/pipermail/blfs-support/2006-August/060862.html

comment:9 by Randy McMurchy, 15 years ago

Resolution: fixed
Status: assignedclosed
Summary: CUPS-1.2.2CUPS-1.2.7

Updated BLFS to CUPS-1.2.7

Note: See TracTickets for help on using tickets.