Opened 2 years ago
Closed 2 years ago
#20178 closed enhancement (fixed)
c-ares-1.33.0
| Reported by: | Douglas R. Reno | Owned by: | Douglas R. Reno |
|---|---|---|---|
| Priority: | normal | Milestone: | 12.2 |
| Component: | BOOK | Version: | git |
| Severity: | medium | Keywords: | |
| Cc: |
Description
New minor version
There's been a lot of these lately.
Change History (3)
comment:1 by , 2 years ago
| Owner: | changed from to |
|---|---|
| Status: | new → assigned |
comment:2 by , 2 years ago
comment:3 by , 2 years ago
| Resolution: | → fixed |
|---|---|
| Status: | assigned → closed |
Note:
See TracTickets
for help on using tickets.

Features: Add DNS cookie support (RFC7873 + RFC9018) to help prevent off-path cache poisoning attacks. PR #833 Implement TCP FastOpen (TFO) RFC7413, which will make TCP reconnects 0-RTT on supported systems. PR #840 Changes: Reorganize source tree. PR #822 Refactoring of connection handling to prevent code duplication. PR #839 New dynamic array data structure to prevent simple logic flaws in array handling in various code paths. PR #841 Bugfixes: ares_destroy() race condition during shutdown due to missing lock. PR #831 Android: Preserve thread name after attaching it to JVM. PR #838 Windows UWP (Store) support fix. PR #845