Opened 15 years ago

Closed 15 years ago

#2047 closed task (duplicate)

Subversion-1.3.2

Reported by: Randy McMurchy Owned by: blfs-book@…
Priority: normal Milestone: 6.2.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Version increment to 1.3.2

http://subversion.tigris.org/

Change History (7)

comment:1 by Randy McMurchy, 15 years ago

Summary: Subversion-1.3.2Subversion-1.4.0

Version increment to 1.4.0

comment:2 by Chris Staub, 15 years ago

It appears that the biggest change, at least as far as the book's instructions are concerned (besides the fact that this latest version claims to support Berkeley DB 4.4) is that apr and neon are no longer bundled with the subversion source tarball. As a result, apr will now have to be a Required dependency of Subversion.

comment:3 by Ag. Hatzimanikas, 15 years ago

I can confirm what Chris said about apr as a required dependancy.

Now there is a new package called subversion-deps.

From the Install file of subversion-1.4.0.

If you're just installing a Subversion client, the Subversion team has created a package containing the minimal prerequisite libraries (Apache Portable Runtime, Neon, and Zlib) called the "dependency package" tarball or zipfile. You should be able to find it at the same place that you downloaded the Subversion tarball itself from. (Note that this is new as of Subversion 1.4.0; previous releases packaged the dependencies in the same tarball as Subversion itself.) If you don't have these libraries installed already, you can simply unpack the dependency package "on top of" the Subversion package. If you are not building from a tarball with the dependency package, you will need to get these yourself. Visit this page, and be sure to download the 0.9.x version:

http://apr.apache.org/download.cgi

comment:4 by Randy McMurchy, 15 years ago

Summary: Subversion-1.4.0Subversion-1.3.2

I suppose the best thing to do here is keep this ticket in queue to update to 1.3.2 and open another ticket for the 1.4.0 update and push the 1.4.0 update to post-BLFS-6.2.

comment:5 by dnicholson@…, 15 years ago

A month late, but I think this is a good choice. I've been running subversion-1.3.2 client and server at home for quite a while. And I the Python and perl SWIG bindings against swig-1.3.25. I even got to use of the svn perl bindings when I imported an svn repository into a git repository.

I did have an issue building the perl bindings resulting in this error:

cc -c  -I/usr/include/apache2   -I/usr/include/apache2   -I../../../../../subver
sion/bindings/swig/perl/libsvn_swig_perl  -I../../../../../subversion/include  -
I../../../../../subversion/bindings/swig -g -O2 -pipe -fno-strict-aliasing -Wdec
laration-after-statement -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2   -DVERS
ION=\"\" -DXS_VERSION=\"\" -fpic "-I/usr/lib/perl5/5.8.8/i686-linux/CORE"   core
.c
In file included from /usr/include/apache2/apr_pools.h:37,
                 from ../../../../../subversion/include/svn_time.h:25,
                 from core.c:1094:
/usr/include/apache2/apr.h:270: error: syntax error before 'apr_off_t'

The problem is that this needs to be built with -DGNU_SOURCE, which are in the CPPFLAGS which configure gets from apr. Unfortunately, the CPPFLAGS are not used in the perl bindings Makefile where they're needed. Fixed with this command before configure:

sed -i.bak 's/@SVN_APR_INCLUDES@/& @CPPFLAGS@/' \
        subversion/bindings/swig/perl/native/Makefile.PL.in

comment:6 by jhuntwork@…, 15 years ago

Just a couple of notes from my recent build of Subversion-1.4.2:

  • The specific neon verison, neon-0.25.5, is required for ra_dav (http repository support) - configure will fail if, for instance, you have neon-0.26.x
  • neon-0.25.5 requires either libxml2 or expat, optionally depends on openssl

comment:7 by Randy McMurchy, 15 years ago

Resolution: duplicate
Status: newclosed

Closing this ticket as a duplicate of #2156. Time constraits prohibit the 1.3.2 update so we'll just update to 1.4.x for the 6.2.1 version of BLFS

Note: See TracTickets for help on using tickets.