Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#2138 closed task (wontfix)

PCI Utilities-2.2.4

Reported by: Randy McMurchy Owned by: Randy McMurchy
Priority: normal Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Change History (7)

comment:1 by alexander@…, 16 years ago

Upgrading to version 2.2.4 will breaks the build of applications that link to libpci.a (such as ddccontrol and vbetool). The fix is to link them also to zlib. Typically, this is done by prepending LIBS="-lz" in front of the ./configure line of the relevant package. I will fix ddccontrol in the Wiki, but the packages in BLFS must be retested individually.

FIXME: how do I know that the retesting process finished? Or is it a better idea, due to the expected breakage, to retarget the ticket post-6.2?

comment:2 by Randy McMurchy, 15 years ago

Milestone: 6.2.06.2.1

comment:3 by Randy McMurchy, 15 years ago

Owner: changed from blfs-book@… to Randy McMurchy
Status: newassigned

comment:4 by Randy McMurchy, 15 years ago

Resolution: fixed
Status: assignedclosed

Updated BLFS to PCI Utilities-2.2.4. Also added a note about linking the Zlib library to packages that may need to link to libpci.a.

comment:5 by Randy McMurchy, 15 years ago

Resolution: fixed
Status: closedreopened

comment:6 by Randy McMurchy, 15 years ago

Resolution: wontfix
Status: reopenedclosed

Closing this ticket as "Won't Fix" because the package breaks the book.

comment:7 by (none), 15 years ago

Milestone: 6.2.1

Milestone 6.2.1 deleted

Note: See TracTickets for help on using tickets.