Opened 16 years ago

Closed 16 years ago

#2178 closed task (fixed)

Does teTex require the obsolete unicode package?

Reported by: Arnold the Frog Owned by: Randy McMurchy
Priority: normal Milestone: 6.2.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

The cm-super tarball is only partially copied to the texmf installation directories. I recently found I needed something else from it: namely file cm-super/type1ec.sty , which is used by the LaTeX back-end for asciidoc.

Unless someone has a better idea, I recommend putting it in /usr/share/texmf-local/cm-super/type1ec.sty

The same back-end also needs ucs.sty: I'm currently trying to track down the best source (the original author has dropped it for want of time) . A version can be found at www.botik.ru/~znamensk/CTAN/macros/latex/contrib/supported/unicode/ucs.sty : I suppose somewhere like /usr/share/texmf-local/tex/ucs/ucs.sty will do for it.

Just in case anyone missed it, after installing new files "by hand" you should call mktexlsr /usr/share/texmf-<whatever> to update the ls-R catalogue file. mktexlsr with no arguments updates all the catalogues it knows about, which is easy but can take a while, as there's a lot in 'texmf'.

Change History (13)

comment:1 by Arnold the Frog, 16 years ago

Sorry, that was a little confused: the ucs.sty is merely part of a complete unicode support package, from (e.g.) http://tug.ctan.org/cgi-bin/getFile.py?fn=/macros/latex/contrib/unicode.zip (use your favourite CTAN mirror here). The natural destination (for the entire package) is /usr/share/texmf/tex/unicode/ (or /usr/local if that's what you prefer).

It's late at night and I can't work out how to change the severity and priority downwards. I'l leave it at that.

comment:2 by Randy McMurchy, 16 years ago

Owner: changed from blfs-book@… to Randy McMurchy
Status: newassigned

comment:3 by Randy McMurchy, 16 years ago

Added instructions to install the cm-super type1ec.sty file.

The unicode stuff is still required before the ticket can be closed.

comment:4 by alexander@…, 16 years ago

The unicode instructions were certainly valid for tetex-2.x. Tetex-3.x contains native Unicode support (via the \usepackage[utf8]{inputenc} command), but there are a few packages that require the contents of the obsolete unicode.zip file. Let me see how Debian handles it.

comment:5 by Randy McMurchy, 16 years ago

Thanks Alexander. I caught your message just in time. I was about to commit the installation of the unicode tarball, but I'll wait for you to add additional info to this ticket before doing anything else.

comment:6 by Randy McMurchy, 16 years ago

Summary: tetex: one useful file not installedDoes teTex require the obsolete unicode package?

Changing the name of the ticket to properly reflect what is still open, and to bump a message in -book to remind Alexander about this issue.

comment:7 by alexander@…, 16 years ago

The original submission of the bug report is clear enough for me to conclude that it's the beyond-the-book package "asciidoc", not the main "tetex" package, who requires the obsolete "unicode" package.

As for the location of type1ec.sty, it doesn't have to live in texmf-local. Please put it to the main texmf tree. Debian puts it in /usr/share/texmf/tex/latex/cm-super/type1ec.sty, as the only file in that directory.

comment:8 by Randy McMurchy, 16 years ago

I can go either way. Some TeX installations use

texmf - for files from the original TeX distribution only texmf-local - for any files added into the system after the original Tex installation texmf-local - only for files developed locally.

Again, I don't care either way. I would, however, like to hear why your preference is the way it is. Is it because that's how Debian does it? Or because the cm-super fonts are in the texmf structure so the type1ec.sty file goes there as well.

I'm not questioning you Alexander, I'm trying to learn.

comment:9 by alexander@…, 16 years ago

It is just inconsistent to put some cm-super files into texmf, and some into texmf-local.

Anyway, what I think that, after moving the type1ec.sty file, the ticket should be closed, and another one (with the 6.2.1 milestone) opened for a new "Additional TeX packages" page (IMHO, cm-super belongs there, together with "cmap" package that I use, and with the "unicode" package).

comment:10 by alexander@…, 16 years ago

On the second thought, the number of additional packages will likely change (possibly down to zero) with the tetex -> texlive switch, because texlive is bigger.

comment:11 by Randy McMurchy, 16 years ago

I moved the type1ec.sty file into the texmf dir structure. I'm leaving the ticket open for two things:

  1. Alexander, would there be any harm in a casual mention of "You may

run across an older application that requires the (URL to the unicode package). This package is now obsolete, and unicode support is now native in TeTex. If you find you must install the obsolete unicode package, follow the instructions at (URL to the unicode package)". Note this could render the native unicode support unstable.

  1. Should we just defer opening a new ticket until after the 6.2.0

release of BLFS? We can then make the appropriate call about which additional packages need mentioning.

comment:12 by alexander@…, 16 years ago

  1. There will be no harm from installation of the unicode package. The native unicode support will not be rendered unusable. However, this is not the only useful beyond-the-base package that other packages depend upon. Until the 6.2.0 release, additional packages can accumulate in the Wiki.
  1. What's wrong with opening a new ticket now with the 6.2.1 milestone?

As for the incomplete installation of cm-super, the issue is completely fixed. If you agree with the two points above, this ticket may be closed.

comment:13 by Randy McMurchy, 16 years ago

Resolution: fixed
Status: assignedclosed

Okay, closing the ticket. I'm not going to mention the unicode package for the reasons you mention. There's no harm in opening a ticket now.

Note: See TracTickets for help on using tickets.