Opened 15 years ago

Closed 15 years ago

#2378 closed task (fixed)

Issues with Java 6u2

Reported by: martyj19 Owned by: blfs-book@…
Priority: high Milestone: 6.3
Component: BOOK Version: SVN
Severity: major Keywords:
Cc:

Description

I noted the following with Java 6. They may or may not be interesting to BLFS.

In Java 6, libdeploy.so is linked against libstdc++.so.5. The result is that the Mozilla plugin will not start. I worked around this by building gcc 3.3.6 and snarfing out libstdc++. I am assuming if you go ahead and do the source build, this won't be an issue. I do not build this from source because I am unwilling to agree to the license (and at least sometimes, source versions of updates haven't been available.)

OpenOffice will not build against Java 6. There are massive problems in the hsqldb subcomponent that appear to be caused by class name conflicts. I worked around by temporarily installing a copy of Java 5 to the side while building OpenOffice and using --with-jdk-home to point to it.

  • Marty Jack

Change History (2)

comment:1 by Randy McMurchy, 15 years ago

Priority: normalhigh
Severity: normalmajor

Here is a relevant bug from the Sun database about the C++ issue: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6542512

All we can do now is have a run-time requirement for libstdc++ from the GCC-3.x package.

An alternative would be to back down to the JD5 for our binary version.

As far as OOo not building against JDK6, that is odd as DJ just updated OOo and I'm quite certain he's building against JDK6.

Waiting for additional input from DJ.

comment:2 by DJ Lucas, 15 years ago

Resolution: fixed
Status: newclosed

I chose the runtime requirement of gcc-3.3.6 for the binary installation. As for OOo, Marty is correct, hsqldb cannot be built with JDK-6. The jar file is shipped in the source tarball, and that is the only patch for OOo is to use the distributed jar. OOo Base (puts the most strain on hsqldb) checks OK at runtime.

Note: See TracTickets for help on using tickets.